summaryrefslogtreecommitdiff
path: root/games-rpg/to-the-moon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-rpg/to-the-moon
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-rpg/to-the-moon')
-rw-r--r--games-rpg/to-the-moon/Manifest3
-rw-r--r--games-rpg/to-the-moon/metadata.xml11
-rw-r--r--games-rpg/to-the-moon/to-the-moon-0.ebuild96
3 files changed, 110 insertions, 0 deletions
diff --git a/games-rpg/to-the-moon/Manifest b/games-rpg/to-the-moon/Manifest
new file mode 100644
index 000000000000..eed3a69bd4fd
--- /dev/null
+++ b/games-rpg/to-the-moon/Manifest
@@ -0,0 +1,3 @@
+DIST ToTheMoon_linux_1389114090.sh 75823678 BLAKE2B de63a8c5eff7d99f5af4fbc85c8e416c7bd7a07fad03dfb0424bf43f410bdbc9a0d064c8892dbb6c9fdc637391f2b2ef6ef40c72c501790ffec0aac8448add21 SHA512 bed844f143ef9c3ff8fe93da186422e84d259229874c331315d8f1c7538fd6c417d6ca1aeecbe6c2a664fad98aff51f4723227d0ef07612acf29f86313f9aa1a
+EBUILD to-the-moon-0.ebuild 2492 BLAKE2B bc3017c2c0e28f78d084a6bbea466ceb3e3411db3a0b5134a8e4bccdc5acfcd7fc00b80e5db0083fdc60320d1c7b75a09968bb3e2e68febbdafa72a147f47883 SHA512 940033be5a9114f29d9e0f8f6dca75e9b68b3d5a0980710a02159cc66ab1f01fab2e208223a3492ed70103052680b86c52dfbc88ef5409d654b512f1f0e475ce
+MISC metadata.xml 325 BLAKE2B 27d3f66c92edf0dda747247d5a31972620750facfbad0d6f82c51c5ca5a99327a0b3918264ab590da1e7250ee8aebb85393981049a33843883238734df348d31 SHA512 a8068b353b7597ae988ad3fd9855339beb981eb11a392483129346d2ee51d658934fb772e8b3f3062e1d14d553e73de9f6bc2f456b4bf5de15902257c22e69ce
diff --git a/games-rpg/to-the-moon/metadata.xml b/games-rpg/to-the-moon/metadata.xml
new file mode 100644
index 000000000000..451145245bfb
--- /dev/null
+++ b/games-rpg/to-the-moon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="bundled-libs">Use bundled libraries</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-rpg/to-the-moon/to-the-moon-0.ebuild b/games-rpg/to-the-moon/to-the-moon-0.ebuild
new file mode 100644
index 000000000000..7560ad283a8c
--- /dev/null
+++ b/games-rpg/to-the-moon/to-the-moon-0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: unbundling sdl-sound breaks the game
+
+EAPI=5
+
+inherit eutils unpacker gnome2-utils games
+
+MY_PN=ToTheMoon
+DESCRIPTION="Two doctors traversing the memories of a dying man to fulfill his last wish"
+HOMEPAGE="http://freebirdgames.com/games/to-the-moon"
+SRC_URI="${MY_PN}_linux_1389114090.sh"
+
+LICENSE="all-rights-reserved bundled-libs? ( LGPL-2 LGPL-2.1 ZLIB )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bundled-libs"
+RESTRICT="fetch bindist splitdebug"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT}/${PN}/${MY_PN}.bin*"
+if [[ ${ARCH} == "amd64" ]] ; then
+ QA_PREBUILT="${QA_PREBUILT} ${GAMES_PREFIX_OPT}/${PN}/lib64/*"
+else
+ QA_PREBUILT="${QA_PREBUILT} ${GAMES_PREFIX_OPT}/${PN}/lib/*"
+fi
+
+RDEPEND="
+ !bundled-libs? (
+ dev-libs/libsigc++:2
+ >=media-libs/libsdl2-2.0.1[X,joystick,opengl,sound,threads,video]
+ media-libs/openal
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-ttf
+ )
+ sys-libs/zlib
+ virtual/opengl"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ einfo
+ einfo "Please buy & download \"${SRC_URI}\" from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move/link it to \"${DISTDIR}\""
+ einfo
+}
+
+src_unpack() {
+ # mojo stuff inside makeself archive, unpack_makeself fails
+ local lastline=$(( $(grep -a -h -n -m 1 -F -e "Extra newline, because in very rare cases (OpenSolaris) stub is directly added after script" "${DISTDIR}/${A}" | cut -d':' -f1) + 1 ))
+ [[ ${lastline} ]] || die "no last line"
+ local offset=$(head -n ${lastline} "${DISTDIR}/${A}" | wc -c)
+ [[ ${offset} ]] || die "no offset"
+ dd ibs=${offset} skip=1 if="${DISTDIR}/${A}" of="${T}"/moon.zip || die
+ unpack_zip "${T}"/moon.zip
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ local libsuffix=$(usex amd64 "64" "")
+ local arch=$(usex amd64 "x86_64" "x86")
+
+ insinto "${dir}"
+ doins -r noarch/{Audio,Data,Fonts,Graphics,Game.ini,mkxp.conf,ToTheMoon.png}
+
+ exeinto "${dir}"
+ doexe ${arch}/${MY_PN}.bin.${arch}
+
+ exeinto "${dir}/lib${libsuffix}"
+ if use bundled-libs ; then
+ doexe ${arch}/lib${libsuffix}/*
+ else
+ doexe ${arch}/lib${libsuffix}/libSDL_sound-1.0.so.1
+ fi
+
+ games_make_wrapper ${PN} "./${MY_PN}.bin.${arch}" "${dir}" "${dir}/lib${libsuffix}"
+ make_desktop_entry ${PN} "To the Moon"
+ newicon -s 32 noarch/${MY_PN}.png ${PN}.png
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}