summaryrefslogtreecommitdiff
path: root/games-rpg/to-the-moon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-rpg/to-the-moon
reinit the tree, so we can have metadata
Diffstat (limited to 'games-rpg/to-the-moon')
-rw-r--r--games-rpg/to-the-moon/Manifest5
-rw-r--r--games-rpg/to-the-moon/metadata.xml11
-rw-r--r--games-rpg/to-the-moon/to-the-moon-0.ebuild96
3 files changed, 112 insertions, 0 deletions
diff --git a/games-rpg/to-the-moon/Manifest b/games-rpg/to-the-moon/Manifest
new file mode 100644
index 000000000000..c7218f7ce3b0
--- /dev/null
+++ b/games-rpg/to-the-moon/Manifest
@@ -0,0 +1,5 @@
+DIST ToTheMoon_linux_1389114090.sh 75823678 SHA256 8272e4693dcf553f4285de4c46e89e1e2e4d5a59a088396b7ea188f935407970 SHA512 bed844f143ef9c3ff8fe93da186422e84d259229874c331315d8f1c7538fd6c417d6ca1aeecbe6c2a664fad98aff51f4723227d0ef07612acf29f86313f9aa1a WHIRLPOOL a3ebaed2e50636d2692ba1b893001cdb327c650d2b5336e928c6f6b74d3a382ed1c392b748e61d7037aa08f4029a524b5b83933f77da57177a9e1bc968385087
+EBUILD to-the-moon-0.ebuild 2511 SHA256 c1255d7a8d294ade068ef2557190b4d381323714fb4602546fde0f77b08ecae3 SHA512 9b7ae680a818efee13a9edbffdec2f62cd9c2c2542dee8b8afb39c76fae48af470bb743398dfb5d646b8c1073b58e9829bdaa3c09abbdbfade993b01817da51c WHIRLPOOL e05e17c97f5a4bbb8c3c0ce3a1a259cbca9b291e5fc031959fc02908c4bc91df1a77f667b3f162db27531202a81025f7fe7f6ad769d917de15500705e2708327
+MISC ChangeLog 2825 SHA256 b4f426ff0f9d748a823657458c6ad82c9525a465d2aafaaaa333545e6a658a7c SHA512 ddb8ceda2e4ef389fca9bce1fd9fcf9604c8fbe6da9c6d1fcbb1d755791120c24727fa11e6a5c458922b261e4e40061418b327bc4f8f25c0e8fdb23ded83e2d3 WHIRLPOOL 5d19609bb03c1088de5d23e0c781aec0a3b746da86e90c3ec59a4db544e0bd7a0315ccf3d6c8aeb17f4af3ae2c32999e19cbc808c6f862251a2205adf4fd585b
+MISC ChangeLog-2015 947 SHA256 ad99393ec5dda5373c4dfb0956760a3d42f14404fda12a039f147e977df3865a SHA512 1edda25bca66d89431e936200b826ebe22bb0394c51b1773b8dc589b86d7d042705f44b0da75183dbed9e9491e50fb421468af68936171d015a53d4194353c3e WHIRLPOOL 81fb8041c84a6f4b276289f7900012a9c08aa5569ffed1906cbf6c2dbd73268b1fc6d0fad5d1affafd8d5418c2b33f21a095245b108a9ebcf6f1d3c37833b1f6
+MISC metadata.xml 325 SHA256 63a0ddff73c7cff99a8fa85f846c6488d6860e5a93e2232de4cfbbc3c09c9305 SHA512 a8068b353b7597ae988ad3fd9855339beb981eb11a392483129346d2ee51d658934fb772e8b3f3062e1d14d553e73de9f6bc2f456b4bf5de15902257c22e69ce WHIRLPOOL ff5c30b3c1f2ca47cd7ef698875c36bfc25bc752be756a895478611d3424aa28242ab6795955ce700d0e50ef8c7e865628503d4956e4fc208834171de91eea73
diff --git a/games-rpg/to-the-moon/metadata.xml b/games-rpg/to-the-moon/metadata.xml
new file mode 100644
index 000000000000..451145245bfb
--- /dev/null
+++ b/games-rpg/to-the-moon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="bundled-libs">Use bundled libraries</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-rpg/to-the-moon/to-the-moon-0.ebuild b/games-rpg/to-the-moon/to-the-moon-0.ebuild
new file mode 100644
index 000000000000..2a2197ed25e6
--- /dev/null
+++ b/games-rpg/to-the-moon/to-the-moon-0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: unbundling sdl-sound breaks the game
+
+EAPI=5
+
+inherit eutils unpacker gnome2-utils games
+
+MY_PN=ToTheMoon
+DESCRIPTION="Indie Adventure RPG, two doctors traversing the memories of a dying man to fulfill his last wish"
+HOMEPAGE="http://freebirdgames.com/games/to-the-moon"
+SRC_URI="${MY_PN}_linux_1389114090.sh"
+
+LICENSE="all-rights-reserved bundled-libs? ( LGPL-2 LGPL-2.1 ZLIB )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="bundled-libs"
+RESTRICT="fetch bindist splitdebug"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT}/${PN}/${MY_PN}.bin*"
+if [[ ${ARCH} == "amd64" ]] ; then
+ QA_PREBUILT="${QA_PREBUILT} ${GAMES_PREFIX_OPT}/${PN}/lib64/*"
+else
+ QA_PREBUILT="${QA_PREBUILT} ${GAMES_PREFIX_OPT}/${PN}/lib/*"
+fi
+
+RDEPEND="
+ !bundled-libs? (
+ dev-libs/libsigc++:2
+ >=media-libs/libsdl2-2.0.1[X,joystick,opengl,sound,threads,video]
+ media-libs/openal
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-ttf
+ )
+ sys-libs/zlib
+ virtual/opengl"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ einfo
+ einfo "Please buy & download \"${SRC_URI}\" from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move/link it to \"${DISTDIR}\""
+ einfo
+}
+
+src_unpack() {
+ # mojo stuff inside makeself archive, unpack_makeself fails
+ local lastline=$(( $(grep -a -h -n -m 1 -F -e "Extra newline, because in very rare cases (OpenSolaris) stub is directly added after script" "${DISTDIR}/${A}" | cut -d':' -f1) + 1 ))
+ [[ ${lastline} ]] || die "no last line"
+ local offset=$(head -n ${lastline} "${DISTDIR}/${A}" | wc -c)
+ [[ ${offset} ]] || die "no offset"
+ dd ibs=${offset} skip=1 if="${DISTDIR}/${A}" of="${T}"/moon.zip || die
+ unpack_zip "${T}"/moon.zip
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ local libsuffix=$(usex amd64 "64" "")
+ local arch=$(usex amd64 "x86_64" "x86")
+
+ insinto "${dir}"
+ doins -r noarch/{Audio,Data,Fonts,Graphics,Game.ini,mkxp.conf,ToTheMoon.png}
+
+ exeinto "${dir}"
+ doexe ${arch}/${MY_PN}.bin.${arch}
+
+ exeinto "${dir}/lib${libsuffix}"
+ if use bundled-libs ; then
+ doexe ${arch}/lib${libsuffix}/*
+ else
+ doexe ${arch}/lib${libsuffix}/libSDL_sound-1.0.so.1
+ fi
+
+ games_make_wrapper ${PN} "./${MY_PN}.bin.${arch}" "${dir}" "${dir}/lib${libsuffix}"
+ make_desktop_entry ${PN} "To the Moon"
+ newicon -s 32 noarch/${MY_PN}.png ${PN}.png
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}