summaryrefslogtreecommitdiff
path: root/games-rpg/to-the-moon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-rpg/to-the-moon
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-rpg/to-the-moon')
-rw-r--r--games-rpg/to-the-moon/Manifest2
-rw-r--r--games-rpg/to-the-moon/to-the-moon-0-r1.ebuild (renamed from games-rpg/to-the-moon/to-the-moon-0.ebuild)38
2 files changed, 21 insertions, 19 deletions
diff --git a/games-rpg/to-the-moon/Manifest b/games-rpg/to-the-moon/Manifest
index 7c3440f08483..c15d236e7cf1 100644
--- a/games-rpg/to-the-moon/Manifest
+++ b/games-rpg/to-the-moon/Manifest
@@ -1,3 +1,3 @@
DIST ToTheMoon_linux_1389114090.sh 75823678 BLAKE2B de63a8c5eff7d99f5af4fbc85c8e416c7bd7a07fad03dfb0424bf43f410bdbc9a0d064c8892dbb6c9fdc637391f2b2ef6ef40c72c501790ffec0aac8448add21 SHA512 bed844f143ef9c3ff8fe93da186422e84d259229874c331315d8f1c7538fd6c417d6ca1aeecbe6c2a664fad98aff51f4723227d0ef07612acf29f86313f9aa1a
-EBUILD to-the-moon-0.ebuild 2494 BLAKE2B 25b7033d023ca9fd495c2be87b240df7ef449f0f3950603ba376a1819c26458fb8c462f3771bfa9d2edd73d3d2da53c64039bd9170de301adfdac57bd5b00906 SHA512 414dd059e5ea14674c3800610336a5ce1fb1c64028d82111b441f226671c5cb3c9384589c736b1fb35500d2e8ce254cf84a26ca254380d165f1e15f5bc66fb24
+EBUILD to-the-moon-0-r1.ebuild 2423 BLAKE2B d9f921cfa744e4ad10134811a20b134aaead701367ba3747cdf2b50fe4010634ddef498271b1ef13343a4711080d34c668ba7e0f1393b382700d5b2245946e50 SHA512 5e5446a9abbbb7d2ee04f44f731bf4442e6d3d28d0ba6e6e126178e1ceb2fae36eb25362d1a4c0e313337676596a852ecd9eb892fcb6e6369f0439802c5b4849
MISC metadata.xml 325 BLAKE2B 27d3f66c92edf0dda747247d5a31972620750facfbad0d6f82c51c5ca5a99327a0b3918264ab590da1e7250ee8aebb85393981049a33843883238734df348d31 SHA512 a8068b353b7597ae988ad3fd9855339beb981eb11a392483129346d2ee51d658934fb772e8b3f3062e1d14d553e73de9f6bc2f456b4bf5de15902257c22e69ce
diff --git a/games-rpg/to-the-moon/to-the-moon-0.ebuild b/games-rpg/to-the-moon/to-the-moon-0-r1.ebuild
index b55f9b6f24f4..619cdd026667 100644
--- a/games-rpg/to-the-moon/to-the-moon-0.ebuild
+++ b/games-rpg/to-the-moon/to-the-moon-0-r1.ebuild
@@ -1,31 +1,34 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# TODO: unbundling sdl-sound breaks the game
-
-EAPI=5
+EAPI=7
-inherit eutils unpacker gnome2-utils games
+inherit desktop gnome2-utils unpacker wrapper
MY_PN=ToTheMoon
DESCRIPTION="Two doctors traversing the memories of a dying man to fulfill his last wish"
HOMEPAGE="http://freebirdgames.com/games/to-the-moon"
SRC_URI="${MY_PN}_linux_1389114090.sh"
+S="${WORKDIR}"/data
LICENSE="all-rights-reserved bundled-libs? ( LGPL-2 LGPL-2.1 ZLIB )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bundled-libs"
+
RESTRICT="fetch bindist splitdebug"
-QA_PREBUILT="${GAMES_PREFIX_OPT}/${PN}/${MY_PN}.bin*"
+QA_PREBUILT="opt/${PN}/${MY_PN}.bin*"
if [[ ${ARCH} == "amd64" ]] ; then
- QA_PREBUILT="${QA_PREBUILT} ${GAMES_PREFIX_OPT}/${PN}/lib64/*"
+ QA_PREBUILT="${QA_PREBUILT} opt/${PN}/lib64/*"
else
- QA_PREBUILT="${QA_PREBUILT} ${GAMES_PREFIX_OPT}/${PN}/lib/*"
+ QA_PREBUILT="${QA_PREBUILT} opt/${PN}/lib/*"
fi
+# TODO: unbundling sdl-sound breaks the game
RDEPEND="
+ sys-libs/zlib
+ virtual/opengl
!bundled-libs? (
dev-libs/libsigc++:2
>=media-libs/libsdl2-2.0.1[X,joystick,opengl,sound,threads,video]
@@ -33,10 +36,11 @@ RDEPEND="
media-libs/sdl2-image[png]
media-libs/sdl2-ttf
)
- sys-libs/zlib
- virtual/opengl"
-
-S=${WORKDIR}/data
+"
+DEPEND="
+ sys-apps/coreutils
+ sys-apps/grep
+"
pkg_nofetch() {
einfo
@@ -50,14 +54,16 @@ src_unpack() {
# mojo stuff inside makeself archive, unpack_makeself fails
local lastline=$(( $(grep -a -h -n -m 1 -F -e "Extra newline, because in very rare cases (OpenSolaris) stub is directly added after script" "${DISTDIR}/${A}" | cut -d':' -f1) + 1 ))
[[ ${lastline} ]] || die "no last line"
+
local offset=$(head -n ${lastline} "${DISTDIR}/${A}" | wc -c)
[[ ${offset} ]] || die "no offset"
+
dd ibs=${offset} skip=1 if="${DISTDIR}/${A}" of="${T}"/moon.zip || die
unpack_zip "${T}"/moon.zip
}
src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
+ local dir=/opt/${PN}
local libsuffix=$(usex amd64 "64" "")
local arch=$(usex amd64 "x86_64" "x86")
@@ -74,20 +80,16 @@ src_install() {
doexe ${arch}/lib${libsuffix}/libSDL_sound-1.0.so.1
fi
- games_make_wrapper ${PN} "./${MY_PN}.bin.${arch}" "${dir}" "${dir}/lib${libsuffix}"
+ make_wrapper ${PN} "./${MY_PN}.bin.${arch}" "${dir}" "${dir}/lib${libsuffix}"
make_desktop_entry ${PN} "To the Moon"
newicon -s 32 noarch/${MY_PN}.png ${PN}.png
-
- prepgamesdirs
}
pkg_preinst() {
- games_pkg_preinst
gnome2_icon_savelist
}
pkg_postinst() {
- games_pkg_postinst
gnome2_icon_cache_update
}