summaryrefslogtreecommitdiff
path: root/games-rpg/openglad/openglad-0.98_p20200907.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
commitf4fc10428424904caf2035cffc442195cb088b2c (patch)
tree72f320d5963e55586cfdeed2b14c72b8191b6327 /games-rpg/openglad/openglad-0.98_p20200907.ebuild
parentfbd9734cedfe790955100b8e4ab3613457d77b1a (diff)
gentoo resync : 28.07.2021
Diffstat (limited to 'games-rpg/openglad/openglad-0.98_p20200907.ebuild')
-rw-r--r--games-rpg/openglad/openglad-0.98_p20200907.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/games-rpg/openglad/openglad-0.98_p20200907.ebuild b/games-rpg/openglad/openglad-0.98_p20200907.ebuild
index 132a5ea39795..33e42ea2dcea 100644
--- a/games-rpg/openglad/openglad-0.98_p20200907.ebuild
+++ b/games-rpg/openglad/openglad-0.98_p20200907.ebuild
@@ -26,7 +26,7 @@ RDEPEND="
media-libs/sdl2-mixer"
DEPEND="${RDEPEND}"
BDEPEND="
- dev-util/premake:4
+ dev-util/premake:5
virtual/pkgconfig"
src_prepare() {
@@ -51,15 +51,25 @@ src_configure() {
append-cppflags $($(tc-getPKG_CONFIG) --cflags "${pkgs[@]}" || die)
append-libs $($(tc-getPKG_CONFIG) --libs "${pkgs[@]}" || die)
- premake4 gmake || die
+ premake5 gmake || die
}
src_compile() {
- emake verbose=y ARCH= CC="$(tc-getCC)" CXX="$(tc-getCXX)" LIBS="${LIBS}"
+ local emakeargs=(
+ config=release
+ verbose=y
+ ARCH= # build assumes this is -m64 and tries to pass it to the compiler
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ LIBS="${LIBS}"
+ ALL_LDFLAGS="${LDFLAGS}" # only used to override -s
+ )
+
+ emake "${emakeargs[@]}"
}
src_install() {
- dobin ${PN}
+ dobin bin/Release/${PN}
insinto /usr/share/${PN}
doins -r builtin cfg extra_campaigns pix sound
@@ -69,5 +79,5 @@ src_install() {
einstalldocs
doicon "${DISTDIR}"/${PN}.png
- make_desktop_entry openglad Openglad
+ make_desktop_entry ${PN} ${PN^}
}