summaryrefslogtreecommitdiff
path: root/games-rpg/freedroidrpg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /games-rpg/freedroidrpg
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'games-rpg/freedroidrpg')
-rw-r--r--games-rpg/freedroidrpg/Manifest4
-rw-r--r--games-rpg/freedroidrpg/freedroidrpg-1.0_rc2-r1.ebuild88
-rw-r--r--games-rpg/freedroidrpg/freedroidrpg-1.0_rc2.ebuild102
-rw-r--r--games-rpg/freedroidrpg/metadata.xml1
4 files changed, 90 insertions, 105 deletions
diff --git a/games-rpg/freedroidrpg/Manifest b/games-rpg/freedroidrpg/Manifest
index 56aab8d1f558..15e791c7ad3e 100644
--- a/games-rpg/freedroidrpg/Manifest
+++ b/games-rpg/freedroidrpg/Manifest
@@ -1,4 +1,4 @@
AUX freedroidrpg-1.0_rc2-fnocommon.patch 2064 BLAKE2B a806eb258ef31ddc2381390cb374390a9fcf6eeac7ebb04058253b08cf4b842a7f089ff06c15a8781a0c21a968ad6637007144a5c279e46496851b38ac3396ec SHA512 3263e2d10fa77ad17631ef1ab775deb73d6c545bdcc805797f0fbd6d167ac68115d09fa5fdde7fdb649e1cab80add74b4a970a864975b1453b32ba1620d4d440
DIST freedroidRPG-1.0rc2.tar.gz 233852127 BLAKE2B c87c2314d17037873acf4fc24ce20790c9ec40c8f7b1ea27e6ab9c543abb671bc50b3ff5b86900f7111d1f1a899213dcb90529d2e39918801c9cc3a42585f02e SHA512 a79afdb089691dd59b0128f34f7068c69fac8c057a0485bca3275f4914b1c9c0f21cbb9102ecdc99911b70456c078dbdeb8981fd7714836cd9535677bcc4d1e7
-EBUILD freedroidrpg-1.0_rc2.ebuild 2363 BLAKE2B 05611d7bbc6ba4fadc5467c09ebd741f2d24fedf94fee6216ac88d1258c1e59154a5c1c7f49e023ac9c5297a45726e8083a465056f8dfcfbd340839ddcbe261d SHA512 06daddac72f9933b8cfa3a99ee8199ef3afb5f52bde96b4156389db4b236ad5b6641abf247719beaa8a1bbbc57a99aaed71ef166cc5c433955bb77c85b80c85f
-MISC metadata.xml 1769 BLAKE2B 9f0b57195e4a16875a3ed7b5fe579fdfc78815547174f777a44234fbac0a86cc4085f1d2116dd63e89b01798aa4a72f13b9eede1c8175935573bd7d8e5abcdd2 SHA512 36ecbf0fc24204612ebc00b1ab5a407097521f24cff5a6a919f71146137f0faa152a83e86151d50108b7b2a4b8a09f6a9428855f6936d174ab4abef1e3a4de28
+EBUILD freedroidrpg-1.0_rc2-r1.ebuild 1864 BLAKE2B e0b3c724ca478d590f1e2a4bba072c8a4616f77dc983125bdac978acf66f6ef51bc3a0064cad7685dd701ce42d3546e114acd6a16fa2dd091f7c20f8bf63ab78 SHA512 9a0e53f644bbd1a327f4a7a5c83f9f451374221842c17b2d4795243cf4e3a93b639715bf878efc04b62607a56d9ede8fa57c2ff9330374917511589868cce226
+MISC metadata.xml 1707 BLAKE2B dc7b8c49a6d25280492a00ddf2d89083ef2fb7b0ecc1b10405f6665da831038a17e00070fae45186bfda4ed8a99b3c964e98a6977c9c42f356e451573acbafe7 SHA512 9aaa4163a9fa823379d21edc220a36bebd41fbc86e22c8388fbbf64356f73648793dedd9551c38b67136aa5aa26ee153603724c6c081b6f209604810f462779b
diff --git a/games-rpg/freedroidrpg/freedroidrpg-1.0_rc2-r1.ebuild b/games-rpg/freedroidrpg/freedroidrpg-1.0_rc2-r1.ebuild
new file mode 100644
index 000000000000..07f51263644e
--- /dev/null
+++ b/games-rpg/freedroidrpg/freedroidrpg-1.0_rc2-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-3 )
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit lua-single python-any-r1 xdg
+
+MY_PV=$(ver_rs 2 '')
+
+DESCRIPTION="Modification of the classical Freedroid engine into an RPG"
+HOMEPAGE="https://www.freedroid.org"
+SRC_URI="ftp://ftp.osuosl.org/pub/freedroid/freedroidRPG-$(ver_cut 1-2)/freedroidRPG-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV^^}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug devtools nls opengl profile +sound"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ ${LUA_DEPS}
+ media-libs/libpng:=
+ media-libs/libsdl[opengl?,sound?,video]
+ >=media-libs/sdl-gfx-2.0.21:=
+ media-libs/sdl-image[jpeg,png]
+ sys-libs/zlib:=
+ devtools? ( media-libs/sdl-ttf )
+ nls? ( virtual/libintl )
+ opengl? (
+ media-libs/glew:0=
+ virtual/opengl
+ )
+ sound? (
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/sdl-mixer[vorbis]
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fnocommon.patch"
+)
+
+pkg_setup() {
+ lua-single_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ python_fix_shebang src/gen_savestruct.py
+ rm data/sound/speak.py || die # unused, prevent installing
+}
+
+src_configure() {
+ local econfargs=(
+ $(use_enable debug backtrace)
+ $(use_enable debug)
+ $(use_enable devtools dev-tools)
+ $(use_enable nls)
+ $(use_enable opengl)
+ $(use_enable profile rtprof)
+ $(use_enable sound)
+ $(use_with debug extra-warnings)
+ )
+ econf "${econfargs[@]}"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if [[ ${REPLACING_VERSIONS} ]]; then
+ local min="1.0_rc1"
+ if ver_test ${REPLACING_VERSIONS} -lt ${min}; then
+ elog "${P} is not compatible with save games before ${min}."
+ elog "Please start a new character."
+ fi
+ fi
+}
diff --git a/games-rpg/freedroidrpg/freedroidrpg-1.0_rc2.ebuild b/games-rpg/freedroidrpg/freedroidrpg-1.0_rc2.ebuild
deleted file mode 100644
index c93b1fa9ce04..000000000000
--- a/games-rpg/freedroidrpg/freedroidrpg-1.0_rc2.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-inherit autotools flag-o-matic desktop python-any-r1 xdg
-
-MY_PV=$(ver_rs 2 '')
-DESCRIPTION="A modification of the classical Freedroid engine into an RPG"
-HOMEPAGE="http://www.freedroid.org"
-SRC_URI="ftp://ftp.osuosl.org/pub/freedroid/freedroidRPG-$(ver_cut 1-2)/freedroidRPG-${MY_PV}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug devtools nls opengl profile sanitize sound"
-
-RDEPEND="
- sys-libs/zlib
- virtual/jpeg:0
- media-libs/libpng:0
- media-libs/libsdl[opengl?,sound?,video]
- media-libs/sdl-image[jpeg,png]
- >=media-libs/sdl-gfx-2.0.21
- nls? ( virtual/libintl )
- opengl? ( virtual/opengl )
- sound? (
- media-libs/libogg
- media-libs/libvorbis
- media-libs/sdl-mixer[vorbis] )
- devtools? ( media-libs/sdl-ttf )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
- nls? ( sys-devel/gettext )
- sanitize? ( || ( sys-devel/gcc[sanitize] sys-devel/clang-runtime[sanitize] ) )"
-
-S="${WORKDIR}/${PN}-${MY_PV^^}"
-
-PATCHES=(
- "${FILESDIR}/${P}-fnocommon.patch"
-)
-
-src_prepare() {
- default
-
- sed -i \
- -e '/^dist_doc_DATA/d' \
- -e '/-pipe/d' \
- -e '/^SUBDIRS/s/pkgs//' \
- Makefile.am || die
- python_fix_shebang src data/sound
- eautoreconf
-}
-
-src_configure() {
- # this can produce strange results due to 'imprecise' math computations
- filter-flags -ffast-math
-
- local myconf=(
- --disable-fastmath
- --with-embedded-lua
- --localedir="${EPREFIX}/usr/share/locale"
- $(use_enable nls)
- $(use_enable opengl)
- $(use_enable sound)
- $(use_enable debug)
- $(use_with debug extra-warnings)
- $(use_enable debug backtrace)
- $(use_enable sanitize sanitize-address)
- $(use_enable profile rtprof)
- $(use_enable devtools dev-tools)
- )
- econf "${myconf[@]}"
-}
-
-src_install() {
- local i
-
- default
- for i in 48 64 96 128
- do
- doicon -s ${i} pkgs/freedesktop/icons/hicolor/${i}x${i}/apps/"${PN}".png
- done
- doicon -s scalable pkgs/freedesktop/icons/hicolor/scalable/apps/freedroidRPG.svg
- make_desktop_entry "${PN}" "Freedroid RPG" "${PN}"
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- local v min="1.0_rc1"
- for v in ${REPLACING_VERSIONS}; do
- if ver_test "${v}" -lt "${min}"; then
- echo
- ewarn "${P} is not compatible with save games before ${min}."
- ewarn "Please start a new character."
- echo
- fi
- done
-}
diff --git a/games-rpg/freedroidrpg/metadata.xml b/games-rpg/freedroidrpg/metadata.xml
index b95ace8f43de..82ad0dfd147d 100644
--- a/games-rpg/freedroidrpg/metadata.xml
+++ b/games-rpg/freedroidrpg/metadata.xml
@@ -29,7 +29,6 @@ fully express their creativity.
<use>
<flag name="devtools">Compile the additional dev tools</flag>
<flag name="profile">Enable the integration of the ingame real-time profiler</flag>
- <flag name="sanitize">Compile with address sanitizer</flag>
</use>
<upstream>
<remote-id type="gitlab">freedroid/freedroid-src</remote-id>