summaryrefslogtreecommitdiff
path: root/games-rpg/freedroid/freedroid-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /games-rpg/freedroid/freedroid-1.2.1.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'games-rpg/freedroid/freedroid-1.2.1.ebuild')
-rw-r--r--games-rpg/freedroid/freedroid-1.2.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-rpg/freedroid/freedroid-1.2.1.ebuild b/games-rpg/freedroid/freedroid-1.2.1.ebuild
new file mode 100644
index 000000000000..abc1f4b7f8a6
--- /dev/null
+++ b/games-rpg/freedroid/freedroid-1.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop
+
+DESCRIPTION="The original Freedroid, a clone of the C64 classic Paradroid"
+HOMEPAGE="https://github.com/ReinhardPrix/FreedroidClassic"
+SRC_URI="https://github.com/ReinhardPrix/FreedroidClassic/archive/refs/tags/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FreedroidClassic-release-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl[joystick,sound,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[mod,vorbis]"
+DEPEND="
+ ${RDEPEND}
+ media-libs/libpng
+ media-libs/libvorbis
+ sys-libs/zlib
+ virtual/jpeg"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newicon graphics/paraicon_48x48.png ${PN}.png
+ make_desktop_entry ${PN} Freedroid ${PN} "Game;"
+}