summaryrefslogtreecommitdiff
path: root/games-rpg/dragonhunt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-rpg/dragonhunt
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-rpg/dragonhunt')
-rw-r--r--games-rpg/dragonhunt/Manifest3
-rw-r--r--games-rpg/dragonhunt/dragonhunt-3.56-r2.ebuild86
-rw-r--r--games-rpg/dragonhunt/metadata.xml8
3 files changed, 97 insertions, 0 deletions
diff --git a/games-rpg/dragonhunt/Manifest b/games-rpg/dragonhunt/Manifest
new file mode 100644
index 000000000000..d52401dc489c
--- /dev/null
+++ b/games-rpg/dragonhunt/Manifest
@@ -0,0 +1,3 @@
+DIST Dragon_Hunt-3.56.tar.gz 2170718 BLAKE2B 4d5b16921867bb7e0b14991184fc4f7a90ca7dbc6c87f4565a4626fb26d413cd4805099bb4973b45fde3758de4845489898c89b5981d34af7e8d03b2874286a5 SHA512 86ca32436088e8cda8993e21ebe6180f8361eb8bf5e052b3744a1db50073826118d1db657d713c7d75cd78c50c78c940caaf7adc5d31ad895d02a44f82b1e72a
+EBUILD dragonhunt-3.56-r2.ebuild 2110 BLAKE2B dcfe8c5410797eaf81b0e53f6264b916928ec06aaf6701e3cbee8fb27e2a9db8992ed27969f3dee96e98c8ed7ef3fa4fad650abeda8430227788c6a19df20dda SHA512 12562488edba40cbc108d8ebdd956b842be85c17b7e5baeaf3594a5c0fbdc79dfd7b592c862d8a7cebce5a1e32b5e6bfe2b7c429dee69426042c70ce624ba199
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-rpg/dragonhunt/dragonhunt-3.56-r2.ebuild b/games-rpg/dragonhunt/dragonhunt-3.56-r2.ebuild
new file mode 100644
index 000000000000..e908b7b28145
--- /dev/null
+++ b/games-rpg/dragonhunt/dragonhunt-3.56-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1
+
+MY_P="Dragon_Hunt-${PV}"
+DESCRIPTION="A simple graphical RPG"
+HOMEPAGE="http://emhsoft.com/dh.html"
+SRC_URI="http://emhsoft.com/dh/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 CC-SA-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/pygame[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Where to look for modules to load.
+ sed -i "s:\.\./modules/:/usr/share/${PN}/:" \
+ code/g.py \
+ code/map_editor.py \
+ code/rpg.py || die
+
+ # Where to look for keybinding
+ sed -i "s:\.\./settings:/etc/${PN}/settings:" \
+ code/g.py || die
+
+ # Save games in ~/.${PN}/.
+ sed -i \
+ -e "s:^\(from os import.*\):\1\, environ:" \
+ -e "s:g.mod_dir.*\"/saves/\?\":environ[\"HOME\"] + \"/.${PN}/\":" \
+ code/g.py code/loadgame.py || die
+
+ # Save maps in ~/.
+ sed -i \
+ -e "s:^\(from os import.*\):\1\, environ:" \
+ -e "s:g.mod_dir.*\"map\.txt\":environ[\"HOME\"]\ +\ \"/dh_map.txt\":" \
+ code/map_editor.py || die
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r modules/*
+
+ insinto /etc/${PN}
+ doins settings.txt
+
+ insinto /usr/$(get_libdir)/${PN}
+ doins code/*.py
+
+ make_wrapper ${PN} "${EPYTHON} ./rpg.py" /usr/$(get_libdir)/${PN}
+ make_wrapper ${PN}-mapeditor "${EPYTHON} ./map_editor.py" \
+ /usr/$(get_libdir)/${PN}
+
+ newicon modules/default/images/buttons/icon.png ${PN}.png
+ make_desktop_entry ${PN} "Dragon Hunt"
+ make_desktop_entry ${PN}-mapeditor "Dragon Hunt - Editor"
+
+ dodoc README.txt docs/{Changelog,Items.txt,example_map.txt,tiles.txt}
+ dodoc -r docs/*.html
+
+ python_optimize "${ED}/usr/$(get_libdir)"/${PN} \
+ "${ED}/usr/share/${PN}/Dark Ages/data/make_map.py"
+}
+
+pkg_postinst() {
+ echo
+ elog "If you use the map editor then note that maps will be saved as"
+ elog "~/dh_map.txt and must be move to the correct module directory"
+ elog "(within /usr/share/${PN}) by hand."
+ echo
+}
diff --git a/games-rpg/dragonhunt/metadata.xml b/games-rpg/dragonhunt/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-rpg/dragonhunt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>