summaryrefslogtreecommitdiff
path: root/games-rpg/deponia-tcj/deponia-tcj-3.3.0156.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /games-rpg/deponia-tcj/deponia-tcj-3.3.0156.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'games-rpg/deponia-tcj/deponia-tcj-3.3.0156.ebuild')
-rw-r--r--games-rpg/deponia-tcj/deponia-tcj-3.3.0156.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/games-rpg/deponia-tcj/deponia-tcj-3.3.0156.ebuild b/games-rpg/deponia-tcj/deponia-tcj-3.3.0156.ebuild
new file mode 100644
index 000000000000..eb2f670cf6b4
--- /dev/null
+++ b/games-rpg/deponia-tcj/deponia-tcj-3.3.0156.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop wrapper
+
+MY_PN="Deponia - The Complete Journey"
+DESCRIPTION="The Complete Journey: The first three Deponia point-and-click adventures"
+HOMEPAGE="https://www.daedalic.com/deponia"
+SRC_URI="DeponiaTCJ_${PV}_Full_DEB_DE_EN_FR_IT_RU_PL_Daedalic_ESD.tar.gz"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist fetch splitdebug strip"
+
+RDEPEND="
+ media-libs/libsdl2[opengl,video]
+ media-libs/openal
+ virtual/opengl
+"
+
+S="${WORKDIR}/${MY_PN}"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/deponia-the-complete-journey"
+ einfo "and move it to your distfiles directory."
+}
+
+src_prepare() {
+ default
+ rm libs64/libz.so.1 || die
+}
+
+src_install() {
+ exeinto "${DIR}"
+ doexe deponia_tcj
+
+ make_wrapper \
+ ${PN} \
+ "env SDL_DYNAMIC_API=\"${EPREFIX}/usr/$(get_libdir)/libSDL2-2.0.so.0\" ./deponia_tcj" \
+ "${DIR}" \
+ "${DIR}/lib"
+
+ insinto "${DIR}"
+ doins -r \
+ config.ini \
+ data{,1,2,3}.vis \
+ deponia{1,2,3}/ \
+ lua/ \
+ version.txt
+
+ exeinto "${DIR}"/lib
+ doexe libs64/*
+
+ make_desktop_entry ${PN} "${MY_PN}" applications-games
+ dodoc readme.txt
+}