summaryrefslogtreecommitdiff
path: root/games-rpg/comi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-rpg/comi
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-rpg/comi')
-rw-r--r--games-rpg/comi/Manifest3
-rw-r--r--games-rpg/comi/comi-1.ebuild67
-rw-r--r--games-rpg/comi/metadata.xml8
3 files changed, 78 insertions, 0 deletions
diff --git a/games-rpg/comi/Manifest b/games-rpg/comi/Manifest
new file mode 100644
index 000000000000..83dfbda879a2
--- /dev/null
+++ b/games-rpg/comi/Manifest
@@ -0,0 +1,3 @@
+DIST comi.jpg 5320 BLAKE2B 4729546c766536a5bb937c1e7eb3cd231ec44146fabda41326f5dbf0a3cb13b57f119a0d28283b1664bcd11ffb652606f0ee2f658d5a0701e5ad15f70a9e8b01 SHA512 b8042241b0badc6950cac8bf0eae7f5e138d5f3fc96f9d3a2108cd3bc69d972bbb12e8f3a416273f0763a1ecfee9b66daff69e211889cd93468439a3036817af
+EBUILD comi-1.ebuild 1476 BLAKE2B 82ff554800ab8b74301d6bca430ba057c62e10cfba4ea8fc2711c37a3144e121f55188fbfcec795323fce82a743d2f345a0b863ef94ec4c2481cc1b092d30059 SHA512 44851095403c5903cb2294617dcfb7c56f7536c00a53d2cb537392bfea7015a5cb82de67f093ee4cf41fef11c0c49ea605d99584ccc46838d3cb2665aa009b4b
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-rpg/comi/comi-1.ebuild b/games-rpg/comi/comi-1.ebuild
new file mode 100644
index 000000000000..91a25419df7f
--- /dev/null
+++ b/games-rpg/comi/comi-1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cdrom estack eutils xdg
+
+DESCRIPTION="The Curse of Monkey Island, the third game in the series"
+HOMEPAGE="https://en.wikipedia.org/wiki/The_Curse_of_Monkey_Island"
+SRC_URI="https://dev.gentoo.org/~chewi/distfiles/${PN}.jpg"
+LICENSE="${PN}"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+RESTRICT="bindist"
+
+RDEPEND=">=games-engines/scummvm-0.4.0"
+
+S="${WORKDIR}"
+
+dotar() {
+ cd "${CDROM_ABSMATCH%/*}" || die
+ eshopts_push -s nocaseglob nullglob
+
+ # Lowercase
+ # Documentation into doc
+ # Remainder into data
+ # Avoid copying files twice
+
+ tar c \
+ --mode=u+w \
+ --ignore-case \
+ --xform='s:^[^a-z]+$:\L\0:x' \
+ --xform='s:.*:data/\0:x' \
+ --xform='s:.*\.(pdf|txt)$:doc/\0:x' \
+ --xform='s:^doc/data/:doc/:x' \
+ --exclude="$(use doc || echo '*.pdf')" \
+ --exclude-from=<(find "${WORKDIR}"/data -type f -printf "%P\n" 2>/dev/null) \
+ *.{txt,pdf} *.la[0-9] resource*/ \
+ | tar x -C "${WORKDIR}"
+
+ assert "tar failed"
+ eshopts_pop
+
+ # Don't prevent CD ejection.
+ cd "${WORKDIR}" || die
+}
+
+src_unpack() {
+ cdrom_get_cds comi.la1 comi.la2
+ dotar
+
+ cdrom_load_next_cd
+ dotar
+}
+
+src_install() {
+ insinto /usr/share/games/scummvm/games/comi
+ doins -r data/*
+
+ # Documentation may be missing.
+ [[ -d doc ]] && dodoc doc/*
+
+ doicon "${DISTDIR}"/${PN}.jpg
+ make_wrapper ${PN} "scummvm comi"
+ make_desktop_entry ${PN} "The Curse of Monkey Island" ${PN}.jpg
+}
diff --git a/games-rpg/comi/metadata.xml b/games-rpg/comi/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-rpg/comi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>