summaryrefslogtreecommitdiff
path: root/games-rpg/broken-age/broken-age-2.4.800398.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /games-rpg/broken-age/broken-age-2.4.800398.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'games-rpg/broken-age/broken-age-2.4.800398.ebuild')
-rw-r--r--games-rpg/broken-age/broken-age-2.4.800398.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-rpg/broken-age/broken-age-2.4.800398.ebuild b/games-rpg/broken-age/broken-age-2.4.800398.ebuild
new file mode 100644
index 000000000000..fed3b2fba16a
--- /dev/null
+++ b/games-rpg/broken-age/broken-age-2.4.800398.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop xdg
+
+MY_PN="BrokenAge"
+DESCRIPTION="A point-and-click adventure from Tim Schafer's Double Fine Productions"
+HOMEPAGE="http://www.brokenagegame.com"
+SRC_URI="${MY_PN}_linux.tar.gz"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ media-libs/libsdl2[abi_x86_32,joystick,opengl,sound,video]
+ virtual/opengl[abi_x86_32]
+"
+
+S="${WORKDIR}"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+ exeinto "${DIR}"
+ doexe ${MY_PN}
+ make_wrapper ${PN} ./${MY_PN} "${DIR}"
+
+ insinto "${DIR}"
+ doins *.pck
+
+ exeinto "${DIR}"/lib
+ doexe lib/libfmod*.so
+
+ make_desktop_entry ${PN} "Broken Age" applications-games
+ dodoc ReadMe.txt
+}