summaryrefslogtreecommitdiff
path: root/games-rpg/bastion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-rpg/bastion
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-rpg/bastion')
-rw-r--r--games-rpg/bastion/Manifest3
-rw-r--r--games-rpg/bastion/bastion-20120620-r1.ebuild84
-rw-r--r--games-rpg/bastion/metadata.xml8
3 files changed, 95 insertions, 0 deletions
diff --git a/games-rpg/bastion/Manifest b/games-rpg/bastion/Manifest
new file mode 100644
index 000000000000..ee0f5e42375c
--- /dev/null
+++ b/games-rpg/bastion/Manifest
@@ -0,0 +1,3 @@
+DIST Bastion-HIB-2012-06-20.sh 1055161705 BLAKE2B 615ff88a3fab37aa70e60d1e692cb0b6a1e03dd90bf6294c65a134cbceb4d59675c341c4fca0b4e08ebda24007df727f09c31adfbe2f5f0e97d8e3b9010af4e1 SHA512 e81b5dfa6f61ec2b35b30693c156a612cd3242c2169f4414b6d66839b7d8cc2e6ea8776f55baae67fa8131ee96bc221e1a15004410612eecaa9f7204dcc673ad
+EBUILD bastion-20120620-r1.ebuild 1739 BLAKE2B 9e9c1c21053d41be2d24e03a363431f5ae7763012356f8e0ab872337c1be3ede525c859f27630fc88e5abfa9abb6f52248009e2709f5c1661dffd6f4aa40ae22 SHA512 e756d62c89e54f8f59f4a14662dc6c996fc97276115bd93bf2955b43062eeb0946151b415d44c13a1df34f05230960d039a8864ed1dd45e6edd311fedcc5b93e
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-rpg/bastion/bastion-20120620-r1.ebuild b/games-rpg/bastion/bastion-20120620-r1.ebuild
new file mode 100644
index 000000000000..4cb7738a2de0
--- /dev/null
+++ b/games-rpg/bastion/bastion-20120620-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils gnome2-utils check-reqs unpacker games
+
+TIMESTAMP=${PV:0:4}-${PV:4:2}-${PV:6:2}
+DESCRIPTION="An original action role-playing game set in a lush imaginative world"
+HOMEPAGE="https://supergiantgames.com/games/bastion/"
+SRC_URI="Bastion-HIB-${TIMESTAMP}.sh"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/Bastion.bin*
+ ${MYGAMEDIR#/}/lib/*
+ ${MYGAMEDIR#/}/lib64/*"
+
+# mono shit: vague dependencies
+RDEPEND="
+ virtual/opengl
+ media-libs/freealut
+ media-libs/openal
+ media-libs/sdl-gfx
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ media-libs/smpeg
+ x11-libs/libX11
+ x11-libs/libXft"
+
+CHECKREQS_DISK_BUILD="2400M"
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ myarch=$(usex amd64 "x86_64" "x86")
+
+ unpack_makeself
+
+ mv instarchive_all{,.tar.lzma} || die
+ mv instarchive_linux_${myarch}{,.tar.lzma} || die
+
+ mkdir ${P} || die
+ cd ${P} || die
+
+ unpack ./../instarchive_{all,linux_${myarch}}.tar.lzma
+}
+
+src_install() {
+ insinto "${MYGAMEDIR}"
+ doins -r *
+
+ newicon -s 256 Bastion.png ${PN}.png
+ make_desktop_entry ${PN}
+ games_make_wrapper ${PN} "./Bastion.bin.${myarch}" "${MYGAMEDIR}" "${MYGAMEDIR}/$(get_libdir)"
+
+ fperms +x "${MYGAMEDIR}"/Bastion.bin.${myarch}
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-rpg/bastion/metadata.xml b/games-rpg/bastion/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-rpg/bastion/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>