summaryrefslogtreecommitdiff
path: root/games-rpg/avadon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-rpg/avadon
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-rpg/avadon')
-rw-r--r--games-rpg/avadon/Manifest3
-rw-r--r--games-rpg/avadon/avadon-1.0.4_p1331768904.ebuild53
-rw-r--r--games-rpg/avadon/metadata.xml8
3 files changed, 64 insertions, 0 deletions
diff --git a/games-rpg/avadon/Manifest b/games-rpg/avadon/Manifest
new file mode 100644
index 000000000000..439eefa10167
--- /dev/null
+++ b/games-rpg/avadon/Manifest
@@ -0,0 +1,3 @@
+DIST avadon-linux-1331768904-bin.txt 109767395 BLAKE2B ba89e4cc9d7374b4c140f36860bb3e2682bc8639503500d0371a7783c0ce7fc1b40ac2c552285f03d564ecae21d5f887f822e6785a30034fdeaba9d0837ee6eb SHA512 7c1acbb1ce3bbfb33052454c9b93060fa97b13fbf4202ee2bb0d70fb59423efc05dfe0bca07cce1e711af9f2757b79c590f237dea5f92aa11aa5979c35d018a7
+EBUILD avadon-1.0.4_p1331768904.ebuild 1237 BLAKE2B 9b10a153d3e102359b91971cfbb4696ca89f10d867c746154c92ca02e28afb4e550fb3c66cc714e0423cf9ab67fa9e301043408dee520e2e337327221bdaa216 SHA512 a43fd6f3b37e3decf7c510e160b2a6fbe43f9a74bc0abe3bc04f808530a7f962d890ae64263e6196c528f3c99875a53e9168c555ab3b6c2aaa37531ea54ff2c7
+MISC metadata.xml 252 BLAKE2B 1b951d2e730631865ae5f379b19ed9de2c8adf2f2786da3f75d0871d967374198ddd9106433f388bdc7050c37063fb28cda4320ae7bdc9a03854838693d9f952 SHA512 90798aff93ec7e3881b882e7b10bb1680e8cb7d82b0ef4280e562ab0c9e8a2daba8afe57333dc64697322267a4b651c00ee9b4fdeb56278ff70c073da7b91638
diff --git a/games-rpg/avadon/avadon-1.0.4_p1331768904.ebuild b/games-rpg/avadon/avadon-1.0.4_p1331768904.ebuild
new file mode 100644
index 000000000000..4a9ff4f3cecd
--- /dev/null
+++ b/games-rpg/avadon/avadon-1.0.4_p1331768904.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop gnome2-utils unpacker
+
+DESCRIPTION="Epic fantasy role-playing adventure in an enormous and unique world"
+HOMEPAGE="https://www.spiderwebsoftware.com/avadon"
+SRC_URI="avadon-linux-${PV#*_p}-bin.txt" # .txt is odd but that's what Humble Bundle sends.
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="fetch bindist"
+
+QA_PREBUILT="opt/${PN}/Avadon"
+
+RDEPEND="media-libs/libsdl[opengl,video]
+ media-libs/openal"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/data"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ local dir=/opt/${PN}
+
+ insinto "${dir}"
+ doins -r "avadon files" icon.bmp
+
+ exeinto "${dir}"
+ newexe Avadon-$(usex amd64 amd64 x86) Avadon
+ dosym "../..${dir}"/Avadon /usr/bin/${PN}
+
+ newicon -s 512 Avadon.png ${PN}.png
+ make_desktop_entry ${PN} "Avadon: The Black Fortress"
+
+ dodoc README-linux.txt
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }
diff --git a/games-rpg/avadon/metadata.xml b/games-rpg/avadon/metadata.xml
new file mode 100644
index 000000000000..3c186688e265
--- /dev/null
+++ b/games-rpg/avadon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>