summaryrefslogtreecommitdiff
path: root/games-roguelike/tome/tome-2.3.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-roguelike/tome/tome-2.3.5.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-roguelike/tome/tome-2.3.5.ebuild')
-rw-r--r--games-roguelike/tome/tome-2.3.5.ebuild96
1 files changed, 60 insertions, 36 deletions
diff --git a/games-roguelike/tome/tome-2.3.5.ebuild b/games-roguelike/tome/tome-2.3.5.ebuild
index cdb3c58fefd5..3e3884187946 100644
--- a/games-roguelike/tome/tome-2.3.5.ebuild
+++ b/games-roguelike/tome/tome-2.3.5.ebuild
@@ -1,97 +1,122 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils games
+EAPI=7
+
+inherit toolchain-funcs
MY_PV=${PV//./}
DESCRIPTION="save the world from Morgoth and battle evil (or become evil ;])"
HOMEPAGE="http://t-o-m-e.net/"
SRC_URI="http://t-o-m-e.net/dl/src/tome-${MY_PV}-src.tar.bz2"
+S="${WORKDIR}"/tome-${MY_PV}-src/src
LICENSE="Moria"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="X Xaw3d gtk sdl"
+IUSE="gtk sdl X Xaw3d"
-RDEPEND=">=sys-libs/ncurses-5:0
- X? ( x11-libs/libX11 )
- Xaw3d? ( x11-libs/libXaw )
+RDEPEND="
+ >=sys-libs/ncurses-5:0=
sdl? (
media-libs/sdl-ttf
media-libs/sdl-image
media-libs/libsdl )
- gtk? ( >=x11-libs/gtk+-2.12.8:2 ) "
-DEPEND="${RDEPEND}
+ gtk? ( >=x11-libs/gtk+-2.12.8:2 )
+ X? ( x11-libs/libX11 )
+ Xaw3d? ( x11-libs/libXaw )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
- x11-misc/makedepend"
+ x11-misc/makedepend
+"
+
+RDEPEND+=" acct-group/gamestat"
-S=${WORKDIR}/tome-${MY_PV}-src/src
+PATCHES=(
+ "${FILESDIR}/"${PN}-2.3.5-gentoo-paths.patch
+ "${FILESDIR}"/${PN}-2.3.5-format.patch
+ "${FILESDIR}"/${PN}-2.3.5-noX.patch
+)
src_prepare() {
- mv makefile.std makefile
- epatch "${FILESDIR}/${PV}-gentoo-paths.patch" \
- "${FILESDIR}"/${P}-format.patch \
- "${FILESDIR}"/${P}-noX.patch
+ mv makefile.std makefile || die
+
+ default
+
sed -i -e '/^CC =/d' makefile || die
sed -i -e "s:xx:x:" ../lib/edit/p_info.txt || die
- sed -i -e "s:GENTOO_DIR:${GAMES_STATEDIR}:" files.c init2.c || die
+ # sed -i -e "s:GENTOO_DIR:${GAMES_STATEDIR}:" files.c init2.c || die
- find .. -name .cvsignore -exec rm -f \{\} +
- find ../lib/edit -type f -exec chmod a-x \{\} +
+ find .. -name .cvsignore -exec rm -f \{\} + || die
+ find ../lib/edit -type f -exec chmod a-x \{\} + || die
}
src_compile() {
- local GENTOO_INCLUDES="" GENTOO_DEFINES="-DUSE_GCU " GENTOO_LIBS="$(pkg-config ncurses --libs)"
+ tc-export CC
+
+ local GENTOO_INCLUDES="" GENTOO_DEFINES="-DUSE_GCU " GENTOO_LIBS="$($(tc-getPKG_CONFIG) ncurses --libs)"
+
if use sdl || use X || use gtk || use Xaw3d; then
GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_EGO_GRAPHICS -DUSE_TRANSPARENCY \
-DSUPPORT_GAMMA"
fi
+
if use sdl || use X || use Xaw3d; then
GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_PRECISE_CMOVIE -DUSE_UNIXSOCK "
fi
+
if use sdl; then
GENTOO_INCLUDES="${GENTOO_INCLUDES} $(sdl-config --cflags)"
GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_SDL "
GENTOO_LIBS="${GENTOO_LIBS} $(sdl-config --libs) -lSDL_image -lSDL_ttf"
fi
+
if use X; then
GENTOO_INCLUDES="${GENTOO_INCLUDES} -I/usr/X11R6/include "
GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_X11 "
GENTOO_LIBS="${GENTOO_LIBS} -L/usr/X11R6/lib -lX11 "
fi
+
if use Xaw3d; then
GENTOO_INCLUDES="${GENTOO_INCLUDES} -I/usr/X11R6/include "
GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_XAW "
GENTOO_LIBS="${GENTOO_LIBS} -L/usr/X11R6/lib -lXaw -lXmu -lXt -lX11 "
fi
+
if use gtk; then
- GENTOO_INCLUDES="${GENTOO_INCLUDES} $(pkg-config gtk+-2.0 --cflags)"
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} $($(tc-getPKG_CONFIG) gtk+-2.0 --cflags)"
GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_GTK2 "
- GENTOO_LIBS="${GENTOO_LIBS} $(pkg-config gtk+-2.0 --libs) "
+ GENTOO_LIBS="${GENTOO_LIBS} $($(tc-getPKG_CONFIG) gtk+-2.0 --libs) "
GTK_SRC_FILE="main-gtk2.c"
GTK_OBJ_FILE="main-gtk2.o"
else
GTK_SRC_FILE=""
GTK_OBJ_FILE=""
fi
+
if use amd64; then
GENTOO_DEFINES="${GENTOO_DEFINES} -DLUA_NUM_TYPE=int "
fi
+
GENTOO_INCLUDES="${GENTOO_INCLUDES} -Ilua -I."
GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_LUA"
+
emake -j1 \
INCLUDES="${GENTOO_INCLUDES}" \
DEFINES="${GENTOO_DEFINES}" \
depend
- emake ./tolua
+
+ emake tolua
+
emake \
COPTS="${CFLAGS}" \
INCLUDES="${GENTOO_INCLUDES}" \
DEFINES="${GENTOO_DEFINES}" \
LIBS="${GENTOO_LIBS} -lm" \
- BINDIR="${GAMES_BINDIR}" \
- LIBDIR="${GAMES_DATADIR}/${PN}" \
+ BINDIR="${EPREFIX}/usr/bin" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)/${PN}" \
GTK_SRC_FILE="${GTK_SRC_FILE}" \
GTK_OBJ_FILE="${GTK_OBJ_FILE}"
}
@@ -99,23 +124,22 @@ src_compile() {
src_install() {
emake -j1 \
DESTDIR="${D}" \
- OWNER="${GAMES_USER}" \
- BINDIR="${GAMES_BINDIR}" \
- LIBDIR="${GAMES_DATADIR}/${PN}" install
- cd ..
+ OWNER="nobody" \
+ BINDIR="${EPREFIX}/usr/bin" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)/${PN}" install
+
+ cd .. || die
dodoc *.txt
- dodir "${GAMES_STATEDIR}"
- touch "${D}/${GAMES_STATEDIR}/${PN}-scores.raw"
- prepgamesdirs
- fperms g+w "${GAMES_STATEDIR}/${PN}-scores.raw"
- #FIXME: something has to be done about this.
- fperms g+w "${GAMES_DATADIR}/${PN}/data"
+ dodir /var/games
+ touch "${ED}/var/games/${PN}-scores.raw" || die
+
+ fperms 660 /var/games/${PN}-scores.raw
+ fowners root:gamestat /var/games/${PN}-scores.raw
+ fperms g+s /usr/bin/${PN}
}
pkg_postinst() {
- games_pkg_postinst
- echo
ewarn "ToME ${PV} is not save-game compatible with 2.3.0 and previous versions."
echo
ewarn "If you have older save files and you wish to continue those games,"