summaryrefslogtreecommitdiff
path: root/games-roguelike/stone-soup/stone-soup-0.27.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /games-roguelike/stone-soup/stone-soup-0.27.1.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'games-roguelike/stone-soup/stone-soup-0.27.1.ebuild')
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.27.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/games-roguelike/stone-soup/stone-soup-0.27.1.ebuild b/games-roguelike/stone-soup/stone-soup-0.27.1.ebuild
index 2c294df13dba..5edf90bf5aa1 100644
--- a/games-roguelike/stone-soup/stone-soup-0.27.1.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.27.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,7 +24,8 @@ SRC_URI="
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
KEYWORDS="amd64 x86"
-IUSE="debug ncurses sound +tiles"
+IUSE="debug ncurses sound test +tiles"
+RESTRICT="!test? ( test )"
RDEPEND="
${LUA_DEPS}
@@ -51,6 +52,7 @@ DEPEND="${RDEPEND}
${PYTHON_DEPS}
$(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
sys-devel/flex
+ test? ( dev-cpp/catch:0 )
tiles? (
media-gfx/pngcrush
sys-libs/ncurses:0
@@ -90,6 +92,12 @@ src_prepare() {
sed -i -e "s/GAME = crawl$/GAME = crawl-${SLOT}/" "${S}/Makefile" \
|| die "Couldn't append slot to executable name"
+
+ # Replace bundled catch2 package with system implementation
+ # https://bugs.gentoo.org/829950
+ if use test; then
+ cp /usr/include/catch2/catch.hpp "${S}/catch2-tests" || die "Couldn't substitute system catch2"
+ fi
}
src_compile() {