summaryrefslogtreecommitdiff
path: root/games-roguelike/scourge/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-roguelike/scourge/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-roguelike/scourge/files')
-rw-r--r--games-roguelike/scourge/files/scourge-0.21.1-Wc++11-narrowing.patch18
-rw-r--r--games-roguelike/scourge/files/scourge-0.21.1-freetype_pkgconfig.patch6
-rw-r--r--games-roguelike/scourge/files/scourge-0.21.1-gcc47.patch4
-rw-r--r--games-roguelike/scourge/files/scourge-0.21.1-respect-AR.patch11
4 files changed, 33 insertions, 6 deletions
diff --git a/games-roguelike/scourge/files/scourge-0.21.1-Wc++11-narrowing.patch b/games-roguelike/scourge/files/scourge-0.21.1-Wc++11-narrowing.patch
new file mode 100644
index 000000000000..a852248c9fc2
--- /dev/null
+++ b/games-roguelike/scourge/files/scourge-0.21.1-Wc++11-narrowing.patch
@@ -0,0 +1,18 @@
+Allow compiling with Clang
+https://bugs.gentoo.org/739330
+
+--- a/src/sdlhandler.cpp
++++ b/src/sdlhandler.cpp
+@@ -1034,10 +1034,10 @@
+ bool SDLHandler::intersects( int x, int y, int w, int h,
+ int x2, int y2, int w2, int h2 ) {
+ SDL_Rect ra = {
+- x, y, w, h
++ static_cast<Sint16>(x), static_cast<Sint16>(y), static_cast<Uint16>(w), static_cast<Uint16>(h)
+ };
+ SDL_Rect rb = {
+- x2, y2, w2, h2
++ static_cast<Sint16>(x2), static_cast<Sint16>(y2), static_cast<Uint16>(w2), static_cast<Uint16>(h2)
+ };
+ return intersects( &ra, &rb );
+ }
diff --git a/games-roguelike/scourge/files/scourge-0.21.1-freetype_pkgconfig.patch b/games-roguelike/scourge/files/scourge-0.21.1-freetype_pkgconfig.patch
index d41ee1a44439..6a5a28d1c7ab 100644
--- a/games-roguelike/scourge/files/scourge-0.21.1-freetype_pkgconfig.patch
+++ b/games-roguelike/scourge/files/scourge-0.21.1-freetype_pkgconfig.patch
@@ -1,7 +1,5 @@
-Index: scourge/configure.in
-===================================================================
---- scourge/configure.in (revision 3411)
-+++ scourge/configure.in (working copy)
+--- a/configure.in
++++ b/configure.in
@@ -56,6 +56,7 @@
# Set up binreloc (for a relocatable autopackage file)
AM_BINRELOC
diff --git a/games-roguelike/scourge/files/scourge-0.21.1-gcc47.patch b/games-roguelike/scourge/files/scourge-0.21.1-gcc47.patch
index 6f3f7b3e2a65..c018d24ee383 100644
--- a/games-roguelike/scourge/files/scourge-0.21.1-gcc47.patch
+++ b/games-roguelike/scourge/files/scourge-0.21.1-gcc47.patch
@@ -1,5 +1,5 @@
---- a/src/squirrel/squtils.h 2012-08-30 18:06:43.474037926 +0200
-+++ b/src/squirrel/squtils.h 2012-08-30 18:14:13.300261523 +0200
+--- a/src/squirrel/squtils.h
++++ b/src/squirrel/squtils.h
@@ -8,6 +8,9 @@
#define SQ_FREE(__ptr,__size) sq_vm_free(__ptr,__size);
#define SQ_REALLOC(__ptr,__oldsize,__size) sq_vm_realloc(__ptr,__oldsize,__size);
diff --git a/games-roguelike/scourge/files/scourge-0.21.1-respect-AR.patch b/games-roguelike/scourge/files/scourge-0.21.1-respect-AR.patch
new file mode 100644
index 000000000000..e4fea442af22
--- /dev/null
+++ b/games-roguelike/scourge/files/scourge-0.21.1-respect-AR.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/780450
+--- a/configure.in
++++ b/configure.in
+@@ -28,6 +28,7 @@ if test "x${CXXFLAGS-notset}" = "xnotset" ; then
+ fi
+ AC_PROG_CXX
+
++AM_PROG_AR
+ dnl Check for ranlib
+ AC_PROG_RANLIB
+