summaryrefslogtreecommitdiff
path: root/games-roguelike/rogue/rogue-5.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-roguelike/rogue/rogue-5.4.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-roguelike/rogue/rogue-5.4.4.ebuild')
-rw-r--r--games-roguelike/rogue/rogue-5.4.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-roguelike/rogue/rogue-5.4.4.ebuild b/games-roguelike/rogue/rogue-5.4.4.ebuild
new file mode 100644
index 000000000000..502c98aec952
--- /dev/null
+++ b/games-roguelike/rogue/rogue-5.4.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit games
+
+MY_P=${PN}${PV}
+DESCRIPTION="The original graphical adventure game that spawned an entire genre"
+HOMEPAGE="http://rogue.rogueforge.net/"
+SRC_URI="http://rogue.rogueforge.net/files/rogue5.4/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses[-tinfo]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ egamesconf \
+ --enable-scorefile="${GAMES_STATEDIR}/${PN}/${PN}.scr" \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}