summaryrefslogtreecommitdiff
path: root/games-roguelike/neon-chrome/neon-chrome-1.1.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /games-roguelike/neon-chrome/neon-chrome-1.1.12.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'games-roguelike/neon-chrome/neon-chrome-1.1.12.ebuild')
-rw-r--r--games-roguelike/neon-chrome/neon-chrome-1.1.12.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-roguelike/neon-chrome/neon-chrome-1.1.12.ebuild b/games-roguelike/neon-chrome/neon-chrome-1.1.12.ebuild
new file mode 100644
index 000000000000..b3d1fdf14e55
--- /dev/null
+++ b/games-roguelike/neon-chrome/neon-chrome-1.1.12.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop xdg-utils
+
+MY_PN="NeonChrome"
+DESCRIPTION="A ruthless top-down cyberpunk shooter with rogue-like elements"
+HOMEPAGE="https://neonchromegame.com/"
+SRC_URI="${MY_PN}-Linux-${PV}.tar"
+# https://dev.gentoo.org/~chewi/distfiles/${PN}.png"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ media-libs/libsdl2[opengl,video]
+ media-libs/openal
+"
+
+S="${WORKDIR}"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+ exeinto "${DIR}"
+ doexe ${MY_PN}
+ make_wrapper ${PN} ./${MY_PN} "${DIR}"
+
+ insinto "${DIR}"
+ doins *.pak *.xml
+
+ dodoc README.txt
+
+# doicon -s 64 "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} "Neon Chrome" applications-games
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }