summaryrefslogtreecommitdiff
path: root/games-roguelike/crossfire-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-roguelike/crossfire-client
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-roguelike/crossfire-client')
-rw-r--r--games-roguelike/crossfire-client/Manifest3
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.71.0-r2.ebuild79
-rw-r--r--games-roguelike/crossfire-client/metadata.xml11
3 files changed, 93 insertions, 0 deletions
diff --git a/games-roguelike/crossfire-client/Manifest b/games-roguelike/crossfire-client/Manifest
new file mode 100644
index 000000000000..be65c3c2e83a
--- /dev/null
+++ b/games-roguelike/crossfire-client/Manifest
@@ -0,0 +1,3 @@
+DIST crossfire-client-1.71.0.tar.bz2 761156 BLAKE2B 6a5938ca8d9c7060f43f5b6a54ff2ed65521ec8ffbc76c10be25ae8802e95d77242edb6d52852410ccd352b51d5fc9edcdb9b85dc618cecfa79cd37ff0212c0f SHA512 86710d684fd7908ea9aaf5ba20bff0f1ba01ff0ba90c3e2847afff9d0db6f60c7b671413c8888b513c992fbf27474e744b79df185d5e2c04afc9d2dce3d8665e
+EBUILD crossfire-client-1.71.0-r2.ebuild 1573 BLAKE2B 741d6525b6acb4c3a5e23e296ae1348c8a47e96d70173e466c76721007a225dea02fc0602b345c81447dd3beac52d59400b198725d0a6410b40dec14b533a785 SHA512 488691c905c146e25847cd2839197167abfa860cd5875ce0cd4337932f585ebb9e870c4d52f79e904d2dcbbaa5c1316419afc41bd67ec563974530d1950f3f33
+MISC metadata.xml 332 BLAKE2B b2b20adc6daa1c491850292a929df2b67738519b81cbab2cd2c2d278176daf4e895a10bc712213abcb41714f27bb0c9e2b1731f970b7381cbf9ffefe6c393666 SHA512 cf046be69b614cd43deba574e8fbd23b566507c694b9f7cbda92d7009d727ac4087de411bf63463561beb3160ecfe7f9fb685574b018466b473535184529ccf7
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.71.0-r2.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.71.0-r2.ebuild
new file mode 100644
index 000000000000..0292fdf40be5
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.71.0-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools toolchain-funcs gnome2-utils
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua opengl sdl sound"
+
+RDEPEND="
+ lua? ( dev-lang/lua:0= )
+ media-libs/libpng:0
+ net-misc/curl
+ opengl? ( virtual/opengl
+ media-libs/freeglut )
+ sdl? ( media-libs/libsdl[video]
+ media-libs/sdl-image[png] )
+ sound? ( media-libs/sdl-mixer[vorbis] )
+ sys-libs/zlib
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -ri -e '/^.TH/s:$: 6:' $(find . -name "*man") || die
+ sed -i -e 's/lua-5.1/lua/' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # bugs in configure script so we cant use $(use_enable ...)
+ local myconf
+
+ use lua && myconf="${myconf} --enable-lua"
+ use sdl || myconf="${myconf} --disable-sdl"
+ use opengl || myconf="${myconf} --disable-opengl"
+ use sound || myconf="${myconf} --disable-sound"
+
+ econf ${myconf}
+}
+
+src_compile() {
+ # bug 139785
+ if use sound ; then
+ emake -C sound-src AR="$(tc-getAR)"
+ fi
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local s
+
+ default
+ domenu gtk-v2/crossfire-client.desktop
+ for s in 16 32 48
+ do
+ newicon -s ${s} pixmaps/${s}x${s}.png ${PN}.png
+ done
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-roguelike/crossfire-client/metadata.xml b/games-roguelike/crossfire-client/metadata.xml
new file mode 100644
index 000000000000..baf8c3afc277
--- /dev/null
+++ b/games-roguelike/crossfire-client/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">crossfire</remote-id>
+ </upstream>
+</pkgmetadata>