summaryrefslogtreecommitdiff
path: root/games-roguelike/angband/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-roguelike/angband/files
reinit the tree, so we can have metadata
Diffstat (limited to 'games-roguelike/angband/files')
-rw-r--r--games-roguelike/angband/files/angband-4.0.5-pie-gcc.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/games-roguelike/angband/files/angband-4.0.5-pie-gcc.patch b/games-roguelike/angband/files/angband-4.0.5-pie-gcc.patch
new file mode 100644
index 000000000000..b4f3c5707d43
--- /dev/null
+++ b/games-roguelike/angband/files/angband-4.0.5-pie-gcc.patch
@@ -0,0 +1,13 @@
+Allow gcc to construct correct partial linking command to ld.
+Otherwise ld gets an incompatible mix of '-pie -r'.
+
+https://bugs.gentoo.org/617982
+diff --git a/src/Makefile b/src/Makefile
+index 79be4cc..d27bb91 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -33,3 +33,3 @@ win/$(PROGNAME).res: win/$(PROGNAME).rc
+ $(PROGNAME).o: $(OBJECTS)
+- $(LD) -nostdlib -Wl,-r -o $@ $(OBJECTS)
++ $(LD) -nostdlib -r -o $@ $(OBJECTS)
+ @printf "%10s %-20s\n" LINK $@