summaryrefslogtreecommitdiff
path: root/games-roguelike/FTL
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-roguelike/FTL
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-roguelike/FTL')
-rw-r--r--games-roguelike/FTL/FTL-1.5.13.ebuild65
-rw-r--r--games-roguelike/FTL/Manifest3
-rw-r--r--games-roguelike/FTL/metadata.xml19
3 files changed, 87 insertions, 0 deletions
diff --git a/games-roguelike/FTL/FTL-1.5.13.ebuild b/games-roguelike/FTL/FTL-1.5.13.ebuild
new file mode 100644
index 000000000000..ab2bc9ddb346
--- /dev/null
+++ b/games-roguelike/FTL/FTL-1.5.13.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="Faster Than Light: A spaceship simulation real-time roguelike-like game"
+HOMEPAGE="http://www.ftlgame.com/"
+SRC_URI="FTL.${PV}.tar.gz"
+
+LICENSE="all-rights-reserved Boost-1.0 free-noncomm MIT bundled-libs? ( FTL LGPL-2.1 ZLIB libpng )"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="bundled-libs"
+RESTRICT="fetch bindist splitdebug"
+
+RDEPEND="
+ sys-devel/gcc[cxx]
+ virtual/opengl
+ !bundled-libs? (
+ media-libs/devil[png]
+ media-libs/freetype:2
+ media-libs/libsdl[X,sound,joystick,opengl,video]
+ sys-libs/zlib
+ )"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT#/}/${PN}/bin/${PN}
+ ${GAMES_PREFIX_OPT#/}/${PN}/lib/*"
+
+S=${WORKDIR}/${PN}
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_prepare() {
+ if ! use bundled-libs ; then
+ # no system lib for libbass available
+ find data/${ARCH}/lib -type f \! -name "libbass*" -delete || die
+ fi
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ doins -r data/resources
+
+ exeinto "${dir}"/bin
+ doexe data/${ARCH}/bin/${PN}
+ exeinto "${dir}"/lib
+ doexe data/${ARCH}/lib/*.so*
+
+ games_make_wrapper ${PN} "${dir}/bin/${PN}" "${dir}" "${dir}/lib"
+ make_desktop_entry ${PN} "Faster Than Light" "/usr/share/pixmaps/FTL.bmp"
+
+ newicon data/resources/exe_icon.bmp FTL.bmp
+ dohtml ${PN}_README.html
+
+ prepgamesdirs
+}
diff --git a/games-roguelike/FTL/Manifest b/games-roguelike/FTL/Manifest
new file mode 100644
index 000000000000..7caa34676fe2
--- /dev/null
+++ b/games-roguelike/FTL/Manifest
@@ -0,0 +1,3 @@
+DIST FTL.1.5.13.tar.gz 197569383 BLAKE2B 29b61c92dc242c6239e236761a89c464efc3889e1d28bbcd3466548090f4ba23450597ef9cd0a7130d0caea1d45a9cfdd87a56a65998dd4da146f1ade5d9a68d SHA512 129aa9ea13b6889520cb637bcbda0452f3dc2e8d93fb0e4d1c7938436d776b39a0a33b4e9d943e058ab5c80dcbb6e7bb874d0a78bd8a2a5a3a7e34159e1faac9
+EBUILD FTL-1.5.13.ebuild 1498 BLAKE2B 91e25c44e253d2802813c7e56a7372fafbc52db36835b9093c58ef20e7f27979cedafadcf0081a830674b3713137752804940e4213f417d6899714282f326537 SHA512 d7dcf52b3f59868e79a273c34edf4e9988ed36729e1fd32cb6faa5660d632177ccba553951006a1c2d4a361313794f105e6b40bb7c11df471c479d622889b54a
+MISC metadata.xml 545 BLAKE2B cbafb1a1af2bbb09c4af83e7158d769d2c1c47f5a76c7ff488956cc0af2acee2eb645de70a2a76a49da7448b22b2f1da43e0288c49b22aadf2b98c857d3196d4 SHA512 f7c2324cd2084736cb1bc7936622f2b33a9509c8c51dc32500683ad8eeb361e4e6e4f7663bc63eb483f02f88aa4f45d7c7d2a43869e69d60b525aed5f665ad1a
diff --git a/games-roguelike/FTL/metadata.xml b/games-roguelike/FTL/metadata.xml
new file mode 100644
index 000000000000..2b826b46e1e1
--- /dev/null
+++ b/games-roguelike/FTL/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alex_y_xu@yahoo.ca</email>
+ <name>Alex Xu</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="bundled-libs">Use bundled libraries.</flag>
+ </use>
+</pkgmetadata>