summaryrefslogtreecommitdiff
path: root/games-puzzle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /games-puzzle
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/Manifest.gzbin17313 -> 17306 bytes
-rw-r--r--games-puzzle/swell-foop/Manifest2
-rw-r--r--games-puzzle/swell-foop/swell-foop-41.1.ebuild45
3 files changed, 47 insertions, 0 deletions
diff --git a/games-puzzle/Manifest.gz b/games-puzzle/Manifest.gz
index 53c90e611701..b59f2e70e549 100644
--- a/games-puzzle/Manifest.gz
+++ b/games-puzzle/Manifest.gz
Binary files differ
diff --git a/games-puzzle/swell-foop/Manifest b/games-puzzle/swell-foop/Manifest
index ecb0cd8efd91..e712766e9e78 100644
--- a/games-puzzle/swell-foop/Manifest
+++ b/games-puzzle/swell-foop/Manifest
@@ -1,3 +1,5 @@
DIST swell-foop-41.0.1.tar.xz 758800 BLAKE2B 5df8870f5be52a4dfec9c012a2496e9b727eb93d01480bedb1c836b8b399f9b42ff36b18c78dad7ca26dd9da6b143229064167423fba3d7630a86d5108e4f3d2 SHA512 b579616cddb77fb3e6d6a8b382fe4b9692a884d62b0907fd551048dbfe28d3f031ac9c8e43e2888ee408a51bccb026109cd9e9ac371b475eaffebb1d9c237c11
+DIST swell-foop-41.1.tar.xz 832672 BLAKE2B 97908acab3bc565f084d97b02f8a6200dc170bd1bdb87ebc4e027881aa75a5111e3ecd24594395266fdfdab586a328df9d15fa8d25105529ec571b36f4fa0e5f SHA512 811638d9b09d7aaa584e56def47900bc866b56ac59120a1df91130f7a6b9555befd18907647874fd69dfa0992cee1c6320dc2bc684b3e5f05f6a25a791ac0a60
EBUILD swell-foop-41.0.1.ebuild 879 BLAKE2B 6ac74e2cf572fc2686f3e87158aad05f6cd629aaba056ee04358d4d5b5cf671323eab2e7e41ecc268be2678346ba2266d1d23677125bae87fca2b4e1135ad145 SHA512 988d03c5505fa6afd877c2082d2c4d6192adf6571e53c2f76fecb6642b01eed60a870a95f869e264fb393319c5812f771a0995b05d52d56be2783763d3dce129
+EBUILD swell-foop-41.1.ebuild 891 BLAKE2B e3c750771f97003af31d028a3b1ddd00c95efb918e341d073fe7c843dc0825b119a7706eec6f9d1419714db688b423b70a8df16a918996e27b3802aa471f3d3a SHA512 670fd3df3cd02a2fe5c0fad8e203709c553621c13c2b8f21bc628251717fe9f711f4b9788c5362eec07d0897d49ccd33badabe28b08a7407f4024953b624e4a6
MISC metadata.xml 250 BLAKE2B 8f7f0fe023d43e380e7861e897e6afcb5de4baefb42ea9c65a57dfc0d204c6f787a99295141832e732ebb08be218da56ba77e2dd9639e4e3aabf718ce4db1d0c SHA512 2684e772dd6d83e4b49f08f2ba22d8a0a753e7b46863489eff1b5d1f2f147ad80ffd93245ca405ac4c747249bc1b754454ec9865fe16da70f9b257051e105fd8
diff --git a/games-puzzle/swell-foop/swell-foop-41.1.ebuild b/games-puzzle/swell-foop/swell-foop-41.1.ebuild
new file mode 100644
index 000000000000..dbf29c588e84
--- /dev/null
+++ b/games-puzzle/swell-foop/swell-foop-41.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Clear the screen by removing groups of colored and shaped tiles"
+HOMEPAGE="https://wiki.gnome.org/Apps/Swell%20Foop"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=x11-libs/gtk+-3.24:3
+ >=media-libs/clutter-1.14.0:1.0
+ >=media-libs/clutter-gtk-1.5.0:1.0
+ >=dev-libs/libgnome-games-support-1.7.1:1=
+ >=dev-libs/libgee-0.14.0:0.8=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}