summaryrefslogtreecommitdiff
path: root/games-puzzle/xwelltris
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-puzzle/xwelltris
reinit the tree, so we can have metadata
Diffstat (limited to 'games-puzzle/xwelltris')
-rw-r--r--games-puzzle/xwelltris/Manifest5
-rw-r--r--games-puzzle/xwelltris/metadata.xml8
-rw-r--r--games-puzzle/xwelltris/xwelltris-1.0.1.ebuild46
3 files changed, 59 insertions, 0 deletions
diff --git a/games-puzzle/xwelltris/Manifest b/games-puzzle/xwelltris/Manifest
new file mode 100644
index 000000000000..e3064b47e750
--- /dev/null
+++ b/games-puzzle/xwelltris/Manifest
@@ -0,0 +1,5 @@
+DIST xwelltris-1.0.1.src.tar.gz 422822 SHA256 c7b6321a9a6e735d4e57ec350adc7a6eabf76b8e9fb9d4cf9d91243da2adb38b SHA512 6b1080c6e6d1b579c441d1f42bb6454dafed62a63790d5798e83cf137db7ff2ddc07db7e89b34402a5249770697cc3f8ad5e6222266142c7b43f6936828f2536 WHIRLPOOL 88e968bcafb8742e17d61532d564a9497cdfc5fc1ade1baa6015ef0c0a19f73cb4c281f03f355e34640033f9e45e142f37103316fcc16bbbf85bf02ab7722b2a
+EBUILD xwelltris-1.0.1.ebuild 972 SHA256 2983e494c4502e1fe4c7243cb2a4a10a75921e28bbb97cfb5c90bc6ca1e7c907 SHA512 6cafbc1d5f8d67b07bfe1a06fdf095008e53dd609b903fd9fdf7b7207afc46752bbdb086a30211ce3128615fb7f63578c4c1444d4ca044ff7364f5fab355e071 WHIRLPOOL c950edbec04b567ef50627bd1bec5a0f3d1a83cd9fd8f62d477e0dee5cec42a8ab3055813da7be46b7590f9aa0e7fabb37cf64aabd1bae2af00cbf0b8ac3adbd
+MISC ChangeLog 2566 SHA256 9a99992cc564fe8d20bdc8a7c726d3e595b22e87d93fc716852518f86478133a SHA512 0651554bcf038045b0fef7ffa664393cc25f237c87424be55fa61a570f0320dc6e24af6c8d874dd22ca6e7180b2f79f1926f8bf99f860710782ef989e943bf34 WHIRLPOOL 768bfb8a51c9448d67210dc01295fccfd3565be8837afa5af133bed8e4a5996a6d61f0ea730ad4497d518a95154e27bbfcedf725c60f71d4a8905e8c50c84706
+MISC ChangeLog-2015 1662 SHA256 57ab26345078db79c7e65805b852502b2839073ec51691b7a9150c2dd46c902f SHA512 32bd966ceaaeef1c7eac6546921bc5ce7bd14bb89eaecc68517235a71c14533e4c3be1fafc05bf16c3e03b93dbcd45632c786003e28a6bf9e3b7f363828cb5f1 WHIRLPOOL 74f262f8c89d61c01793ef2a4d36611c8da590c49b712ca07db5962aa7cf032c57c958a76174437214f02c1d9a3e401151fa440ab7e37a906f9c1f426979323a
+MISC metadata.xml 249 SHA256 943b9ce0cd072229b43569ab668dd7ec741d9dfefd942c8921dabd4490b27b0c SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118 WHIRLPOOL b10e21575c78e201a652c8582cd16e3f7c86b13dd20a30f4cea44066fb139440b3c186147dbaae83478f11a20b6f457a99c8b29ee1239a4caaa21eee01250088
diff --git a/games-puzzle/xwelltris/metadata.xml b/games-puzzle/xwelltris/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-puzzle/xwelltris/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
new file mode 100644
index 000000000000..356cf57dc20d
--- /dev/null
+++ b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit games
+
+DESCRIPTION="2.5D tetris like game"
+HOMEPAGE="http://xnc.jinr.ru/xwelltris/"
+SRC_URI="http://xnc.jinr.ru/xwelltris/src/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image[gif]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL_PROGRAM/s/-s //' \
+ src/Make.common.in || die
+ sed -i \
+ -e "/GLOBAL_SEARCH/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
+ src/include/globals.h.in || die
+}
+
+src_configure() {
+ # configure/build process is pretty messed up
+ egamesconf --with-sdl
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_install() {
+ dodir "${GAMES_BINDIR}" "${GAMES_DATADIR}/${PN}" /usr/share/man
+ emake install \
+ INSTDIR="${D}/${GAMES_BINDIR}" \
+ INSTLIB="${D}/${GAMES_DATADIR}/${PN}" \
+ INSTMAN=/usr/share/man
+ dodoc AUTHORS Changelog README*
+ prepgamesdirs
+}