summaryrefslogtreecommitdiff
path: root/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/xwelltris/xwelltris-1.0.1.ebuild')
-rw-r--r--games-puzzle/xwelltris/xwelltris-1.0.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
new file mode 100644
index 000000000000..eb2e02cbf21d
--- /dev/null
+++ b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit games
+
+DESCRIPTION="2.5D tetris like game"
+HOMEPAGE="http://xnc.jinr.ru/xwelltris/"
+SRC_URI="http://xnc.jinr.ru/xwelltris/src/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image[gif]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL_PROGRAM/s/-s //' \
+ src/Make.common.in || die
+ sed -i \
+ -e "/GLOBAL_SEARCH/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
+ src/include/globals.h.in || die
+}
+
+src_configure() {
+ # configure/build process is pretty messed up
+ egamesconf --with-sdl
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_install() {
+ dodir "${GAMES_BINDIR}" "${GAMES_DATADIR}/${PN}" /usr/share/man
+ emake install \
+ INSTDIR="${D}/${GAMES_BINDIR}" \
+ INSTLIB="${D}/${GAMES_DATADIR}/${PN}" \
+ INSTMAN=/usr/share/man
+ dodoc AUTHORS Changelog README*
+ prepgamesdirs
+}