summaryrefslogtreecommitdiff
path: root/games-puzzle/xpired/xpired-1.22-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/xpired/xpired-1.22-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/xpired/xpired-1.22-r1.ebuild')
-rw-r--r--games-puzzle/xpired/xpired-1.22-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-puzzle/xpired/xpired-1.22-r1.ebuild b/games-puzzle/xpired/xpired-1.22-r1.ebuild
new file mode 100644
index 000000000000..8ea6b7243bf8
--- /dev/null
+++ b/games-puzzle/xpired/xpired-1.22-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A Sokoban-styled puzzle game with lots more action"
+HOMEPAGE="http://xpired.sourceforge.net"
+SRC_URI="mirror://sourceforge/xpired/${P}-linux_source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/sdl-gfx
+ media-libs/sdl-image[jpeg]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/src"
+
+PATCHES=( "${FILESDIR}"/${P}-ldflags.patch )
+
+src_compile() {
+ emake \
+ PREFIX=/usr \
+ SHARE_PREFIX=/usr/share/xpired
+}
+
+src_install() {
+ emake \
+ PREFIX="${D}/usr" \
+ SHARE_PREFIX="${D}/usr/share/${PN}" \
+ install
+
+ newicon img/icon.bmp ${PN}.bmp
+ make_desktop_entry xpired Xpired /usr/share/pixmaps/${PN}.bmp
+ make_desktop_entry xpiredit "Xpired Level Editor"
+
+ einstalldocs
+}