summaryrefslogtreecommitdiff
path: root/games-puzzle/xblockout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-puzzle/xblockout
reinit the tree, so we can have metadata
Diffstat (limited to 'games-puzzle/xblockout')
-rw-r--r--games-puzzle/xblockout/Manifest6
-rw-r--r--games-puzzle/xblockout/files/xblockout-1.1.6-font.patch46
-rw-r--r--games-puzzle/xblockout/metadata.xml8
-rw-r--r--games-puzzle/xblockout/xblockout-1.1.6.ebuild54
4 files changed, 114 insertions, 0 deletions
diff --git a/games-puzzle/xblockout/Manifest b/games-puzzle/xblockout/Manifest
new file mode 100644
index 000000000000..cddaf2edda78
--- /dev/null
+++ b/games-puzzle/xblockout/Manifest
@@ -0,0 +1,6 @@
+AUX xblockout-1.1.6-font.patch 1531 SHA256 fd1707ce1775804469fec94d71ec97263686324164f50be7aeb3f88e1402e9be SHA512 adfc6ad87048c4c021e8989886011c8dfa8736778ac12fefacbbffc114272f4a5ee60a997f35d817d22bbd9eb348c7e40701bd25bc1cf0d5924add71fc77e450 WHIRLPOOL 8add3633f33d6d38c59a7449984509e5bed151d65d3ce6ebe7199c7ffabadc157ca2f77e6bbad0628621f47b8768cdc7900f399b1fa38d60973acaf5f395c758
+DIST xbl-1.1.6.tar.gz 136504 SHA256 85f456b6aca15f1642bbd233872250918432f0b5252d4b0d681bc2394fda5f84 SHA512 96bf0460863698136a61b43260feed0e90e7ca5b6613d54c8ca98f51557a3d235597eeab46141cd6771aa0bf4fe019c5e4291dd826338e186cc905e3837531e0 WHIRLPOOL 94f3bd29f13d2e0774e491f0624b7b5d912e37c071fb9490d2b5a5320990731193cd78235aa49e860c2e7b976ced5223c5875a82baaaa846492154ebc5fe2a20
+EBUILD xblockout-1.1.6.ebuild 1127 SHA256 67befca1509eb057617397d8f36ef2c69d618f3cd01004524fae9be0216c8afe SHA512 c774a1d3856738ce485fcef51030e929130786160501d6531560247b04d09534d8b6303d3dd8cf0bdc041013a128f1622a35aa270f7b49734ec2b86d56c35901 WHIRLPOOL deb80537bf610ee411cbd127136fa3ec4239ca4a149fc2e53a593e1fe0199167546d28bec6ceab011953a0df09e444cf7eef11eeb390022ad7d76a07f0d3eb3a
+MISC ChangeLog 2472 SHA256 ad5c0bcbe77fcbd148500e62bfa2904c80e59f6167e8339c3c41e70c6087e55d SHA512 b3c466264db87d78432e3c81a87e65ba427b299a6450381f9371f272834b211c24f4cb8e9c1d045a8da9d870f7dac76cb10f7de57d76294bfdd07c27c1ed4f73 WHIRLPOOL 2c482fbf317c1c183435198ba06405e7e3ae59b26b7991424186ea5ac9171b609dde609f1ce8ddc137d0455077a1df991d52b9dcab3d3b62d291a5a0c3ac0165
+MISC ChangeLog-2015 3968 SHA256 7937ed3af3207bff5dadb8ede1d2f4b2f2db2eff19446e6040112afc4db824ea SHA512 43d1a3dd58347b04b1451311d4336ee675251a1ddbcca2d7040ba2e551b92b90f3fb02eaf395465166dac1ac2ad010946f2c108ad24acff9be207e7e5305b5e7 WHIRLPOOL 05156cc50bbb0dd26b9d9824f817817626022380b795b7ffe9470a40bc7b939582dbc140aa6e31c47e8c28e4db85ed98348b789f6b32b74165cc5dc4c3a467fa
+MISC metadata.xml 249 SHA256 943b9ce0cd072229b43569ab668dd7ec741d9dfefd942c8921dabd4490b27b0c SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118 WHIRLPOOL b10e21575c78e201a652c8582cd16e3f7c86b13dd20a30f4cea44066fb139440b3c186147dbaae83478f11a20b6f457a99c8b29ee1239a4caaa21eee01250088
diff --git a/games-puzzle/xblockout/files/xblockout-1.1.6-font.patch b/games-puzzle/xblockout/files/xblockout-1.1.6-font.patch
new file mode 100644
index 000000000000..bb0302963bdc
--- /dev/null
+++ b/games-puzzle/xblockout/files/xblockout-1.1.6-font.patch
@@ -0,0 +1,46 @@
+--- initmenu.c.old 2008-10-27 23:23:43.000000000 +0100
++++ initmenu.c 2008-10-27 23:22:52.000000000 +0100
+@@ -408,19 +408,17 @@
+ XCharStruct overall_return ;
+
+ m->xfont = XLoadQueryFont( x->display , opt->thefont ) ;
+- m->font = XLoadFont( x->display , opt->thefont ) ;
+ if ( opt->verbose )
+ {
+ fprintf(stderr,"font=%s\n", opt->thefont) ;
+ }
+- if ( m->font==BadAlloc || m->font==BadName || m->xfont==0 )
++ if ( m->xfont==0 )
+ {
+ fprintf(stderr,"Some problems when loading a font... trying others\n") ;
+ m->xfont = XLoadQueryFont( x->display ,
+ "-*-*-*-*-*-*-*-*-*-*-*-*-*-*" ) ;
+- m->font = XLoadFont( x->display ,
+- "-*-*-*-*-*-*-*-*-*-*-*-*-*-*" ) ;
+- if ( m->font==BadAlloc || m->font==BadName || m->xfont==0 )
++ m->font = m->xfont->fid;
++ if ( m->xfont==0 )
+ {
+ fprintf(stderr,"You haven't -*-*-*-*-*-*-*-*-*-*-*-*-*-*\n");
+ fprintf(stderr,"Have you A font?\n");
+@@ -428,17 +426,17 @@
+ exit(1) ;
+ }
+ }
++ m->font = m->xfont->fid;
+ m->xfont2 = XLoadQueryFont( x->display , opt->thefont2 ) ;
+- m->font2 = XLoadFont( x->display , opt->thefont2 ) ;
+ if ( opt->verbose )
+ {
+ fprintf(stderr,"font2=%s\n", opt->thefont2) ;
+ }
+- if ( m->font2==BadAlloc || m->font2==BadName || m->xfont2==0 )
++ if ( m->xfont2==0 )
+ {
+- m->font2 = m->font ;
+ m->xfont2 = m->xfont ;
+ }
++ m->font2 = m->xfont2->fid;
+
+ xgc.background = x->back_pixel ;
+ xgc.foreground = opt->backcolor!=7 ? x->white_pixel : x->black_pixel;
diff --git a/games-puzzle/xblockout/metadata.xml b/games-puzzle/xblockout/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-puzzle/xblockout/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-puzzle/xblockout/xblockout-1.1.6.ebuild b/games-puzzle/xblockout/xblockout-1.1.6.ebuild
new file mode 100644
index 000000000000..a2d04f528c41
--- /dev/null
+++ b/games-puzzle/xblockout/xblockout-1.1.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools flag-o-matic eutils games
+
+DESCRIPTION="X Window block dropping game in 3 Dimension"
+HOMEPAGE="http://perso.univ-lyon1.fr/thierry.excoffier/XBL/"
+SRC_URI="http://perso.univ-lyon1.fr/thierry.excoffier/XBL/xbl-${PV}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/xbl-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-font.patch
+ sed -i \
+ -e '/^CC/d' \
+ -e 's:-lm:-lm -lX11:' \
+ -e '/DGROUP_GID/d' \
+ -e "s:-g$:${CFLAGS}:" \
+ Makefile.in || die
+ # Don't know about other archs. --slarti
+ use amd64 && filter-flags "-fweb"
+ eautoreconf
+}
+
+src_compile() {
+ emake \
+ USE_SETGID= \
+ SCOREDIR="${GAMES_DATADIR}/${PN}" \
+ RESOURCEDIR="${GAMES_DATADIR}/${PN}" \
+ LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ newgamesbin bl xbl
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins Xbl.ad Xbl
+
+ newman xbl.man xbl.6
+ dodoc README xbl-README
+ dohtml *.html *.gif
+ make_desktop_entry xbl XBlockOut
+ prepgamesdirs
+}