summaryrefslogtreecommitdiff
path: root/games-puzzle/world-of-goo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/world-of-goo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/world-of-goo')
-rw-r--r--games-puzzle/world-of-goo/Manifest3
-rw-r--r--games-puzzle/world-of-goo/metadata.xml8
-rw-r--r--games-puzzle/world-of-goo/world-of-goo-1.41-r2.ebuild66
3 files changed, 77 insertions, 0 deletions
diff --git a/games-puzzle/world-of-goo/Manifest b/games-puzzle/world-of-goo/Manifest
new file mode 100644
index 000000000000..9e80b891e04d
--- /dev/null
+++ b/games-puzzle/world-of-goo/Manifest
@@ -0,0 +1,3 @@
+DIST WorldOfGooSetup.1.41.tar.gz 66428181 BLAKE2B 476c05f0b3f78fa952728b9f7b5b95942e7f3e57dde4842144ccaa28c9ad2d2c264b1a2277ba5a1f3edf25cb812c72a0380b0d26b2bc99dd9a77116badcf5477 SHA512 278dfb983cf9cf4de87f13d94f5e75b3830af07523e2ddc7a443d5afb6fead130ed50440357554986b5b0d99c17651f77ae11298f51f9f1072ebd40287cad396
+EBUILD world-of-goo-1.41-r2.ebuild 1472 BLAKE2B 4464e577d888be78e0fdabc8a9026724ad3f249bb2b90b7e4d9369e9b84a051be4725b6d488f4cf880b56f44681e5115f64e7dcc7b56782bf1e9e1044d0b2877 SHA512 ee612026cb24862f5ebba0e69a5089dcbabc5a4dae3f9efdf04b65188e708cb06e779c91c67a3accdf1a9a3c36b75547ea7f491dbb9d02724a6c84171f725fe7
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-puzzle/world-of-goo/metadata.xml b/games-puzzle/world-of-goo/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-puzzle/world-of-goo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-puzzle/world-of-goo/world-of-goo-1.41-r2.ebuild b/games-puzzle/world-of-goo/world-of-goo-1.41-r2.ebuild
new file mode 100644
index 000000000000..51f7f12ff569
--- /dev/null
+++ b/games-puzzle/world-of-goo/world-of-goo-1.41-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop eutils # eutils for make_wrapper()
+
+DESCRIPTION="A puzzle game with a strong emphasis on physics"
+HOMEPAGE="http://2dboy.com/"
+
+if [[ ${PN} == *-demo ]] ; then
+ MY_PN="WorldOfGooDemo"
+ SRC_URI="${MY_PN}.${PV}.tar.gz"
+else
+ MY_PN="WorldOfGoo"
+ SRC_URI="${MY_PN}Setup.${PV}.tar.gz"
+fi
+
+LICENSE="2dboy-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="fetch bindist strip"
+
+RDEPEND="media-libs/libsdl[alsa,sound,opengl,video]
+ media-libs/sdl-mixer[vorbis]
+ sys-libs/glibc
+ virtual/opengl
+ virtual/glu
+ >=sys-devel/gcc-3.4"
+
+S="${WORKDIR}/${MY_PN}"
+dir="/opt/${PN}"
+
+QA_PREBUILT="${dir:1}/${MY_PN%Demo}.bin32
+ ${dir:1}/${MY_PN%Demo}.bin64"
+
+pkg_nofetch() {
+ if [[ ${PN} == *-demo ]] ; then
+ elog "To download the demo, visit http://worldofgoo.com/dl2.php?lk=demo"
+ elog "and download ${A} and place it in your DISTDIR directory."
+ else
+ elog "Download ${A} from ${HOMEPAGE}"
+ elog "and place it in your DISTDIR directory."
+ fi
+}
+
+src_install() {
+ exeinto "${dir}"
+ doexe ${MY_PN%Demo}{,.$(usex amd64 bin64 bin32)}
+
+ make_wrapper ${PN} "${dir}"/${MY_PN%Demo}
+
+ insinto "${dir}"
+ doins -r icons properties res
+ newicon icons/scalable.svg ${PN}.svg
+
+ if [[ ${PN} == *-demo ]] ; then
+ make_desktop_entry ${PN} "World of Goo (Demo)"
+ else
+ make_desktop_entry ${PN} "World of Goo"
+ fi
+
+ dodoc linux-issues.txt
+ docinto html
+ dodoc readme.html
+}