summaryrefslogtreecommitdiff
path: root/games-puzzle/wakkabox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/wakkabox
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/wakkabox')
-rw-r--r--games-puzzle/wakkabox/Manifest4
-rw-r--r--games-puzzle/wakkabox/files/wakkabox-1.1.0-gentoo.patch53
-rw-r--r--games-puzzle/wakkabox/metadata.xml8
-rw-r--r--games-puzzle/wakkabox/wakkabox-1.1.0-r1.ebuild30
4 files changed, 95 insertions, 0 deletions
diff --git a/games-puzzle/wakkabox/Manifest b/games-puzzle/wakkabox/Manifest
new file mode 100644
index 000000000000..83dc8213be69
--- /dev/null
+++ b/games-puzzle/wakkabox/Manifest
@@ -0,0 +1,4 @@
+AUX wakkabox-1.1.0-gentoo.patch 1768 BLAKE2B 57fc63581b1fecaf579fc70cee8a693c4c55a27c19afe85442e3a36b5d7fcf693dba91ff4cf52ab5f21813f15250abc3352930c333636780f0ff9c478b255c32 SHA512 28c261d77372ffad9815dc6d40118595d7896bafb352237ce708f028ac50ae0530d5a61f75ece36c35ec7f041da9979c9cfa37c19dae1e83ef9ddb34ffa4bf94
+DIST wakkabox-1.1.0.tar.gz 158231 BLAKE2B f756cf98135591dbae60f00a4e85f4286204f0206196b032c2ac547ae5f1259a4b228f673aed047a8848a6500abaccc0ea69f8eb47e1950309fadc9738e684da SHA512 a97fcf382c3703fa59d6c2159397cb795b698d2a28253a7e60690b24b3d72b4950b9a7c569600bac0dc637b9d9a52577a45944036518cf5e79c601b377a092be
+EBUILD wakkabox-1.1.0-r1.ebuild 613 BLAKE2B ac2beb4615cbb105771f47ad5a719acb72dab76cf9a440422fb2aa86392c1c745f7e3476050055b3234e283feef0daa5a718b4c9235adffbf8a78bfbc8307c21 SHA512 98d132cf9f39b470f20accdaa35fefb3b558776bc362e923b350cfa78c82b7914876b877e64f9b72bfccd4f35be507d3f01ab944a3274dd5557ab6e6c49bd800
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-puzzle/wakkabox/files/wakkabox-1.1.0-gentoo.patch b/games-puzzle/wakkabox/files/wakkabox-1.1.0-gentoo.patch
new file mode 100644
index 000000000000..ad82efaeab94
--- /dev/null
+++ b/games-puzzle/wakkabox/files/wakkabox-1.1.0-gentoo.patch
@@ -0,0 +1,53 @@
+--- a/configure.ac.old 2015-02-26 23:25:34.146334845 +0100
++++ b/configure.ac 2015-02-26 23:25:47.978312858 +0100
+@@ -17,6 +17,7 @@
+ CFLAGS="$CFLAGS $SDL_CFLAGS"
+-LIBS="$LIBS $SDL_LIBS"
++LIBS="$LIBS -lm $SDL_LIBS"
+
+-AC_SUBST(CFLAGS LIBS)
++AC_SUBST(CFLAGS)
++AC_SUBST(LIBS)
+
+ AC_OUTPUT( Makefile )
+--- a/configure.ac.old 2015-02-26 23:33:25.801552821 +0100
++++ b/configure.ac 2015-02-26 23:33:47.509542361 +0100
+@@ -1,4 +1,4 @@
+-AC_INIT( wakkabox.c )
++AC_INIT([[wakkabox.c]])
+ AC_CANONICAL_HOST
+ AC_CANONICAL_TARGET
+
+--- a/wakkabox.c.old 2015-02-26 23:43:26.146386413 +0100
++++ b/wakkabox.c 2015-02-26 23:44:39.647389816 +0100
+@@ -249,22 +249,22 @@
+ printf("Loading bmp files from %s...", DATADIR);
+
+ smallblockFname = (char*)malloc( strlen("smallblock.bmp")
+- + strlen(DATADIR) );
++ + strlen(DATADIR) + 2);
+ medblockhFname = (char*)malloc( strlen("medblockh.bmp")
+- + strlen(DATADIR) );
++ + strlen(DATADIR) + 2);
+ medblockvFname = (char*)malloc( strlen("medblockv.bmp")
+- + strlen(DATADIR) );
++ + strlen(DATADIR) + 2);
+ bigblockFname = (char*)malloc( strlen("bigblock.bmp")
+- + strlen(DATADIR) );
++ + strlen(DATADIR) + 2);
+
+ smallblockLocalName = (char*)malloc( strlen("smallblock.bmp")
+- + strlen(".") );
++ + strlen(".") + 2);
+ medblockhLocalName = (char*)malloc( strlen("medblockh.bmp")
+- + strlen(".") );
++ + strlen(".") + 2);
+ medblockvLocalName = (char*)malloc( strlen("medblockv.bmp")
+- + strlen(".") );
++ + strlen(".") + 2);
+ bigblockLocalName = (char*)malloc( strlen("bigblock.bmp")
+- + strlen(".") );
++ + strlen(".") + 2);
+
+
+ sprintf( smallblockFname, "%s/smallblock.bmp", DATADIR );
diff --git a/games-puzzle/wakkabox/metadata.xml b/games-puzzle/wakkabox/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-puzzle/wakkabox/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-puzzle/wakkabox/wakkabox-1.1.0-r1.ebuild b/games-puzzle/wakkabox/wakkabox-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..a04dd8404b70
--- /dev/null
+++ b/games-puzzle/wakkabox/wakkabox-1.1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DESCRIPTION="A simple block-pushing game"
+HOMEPAGE="http://kenn.frap.net/wakkabox/"
+SRC_URI="http://kenn.frap.net/wakkabox/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.0.1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-gentoo.patch
+ rm aclocal.m4
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon bigblock.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Wakkabox" /usr/share/pixmaps/${PN}.bmp
+}