summaryrefslogtreecommitdiff
path: root/games-puzzle/torrent/torrent-0.8.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-05 19:20:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-05 19:20:12 +0100
commita4e37a9aeeef82eba5858dbc609f65b838b0f836 (patch)
treee4348e571adc5713a413fbaf411d45c511a7da31 /games-puzzle/torrent/torrent-0.8.2-r2.ebuild
parentd03ec6c0e9c1683a824ce77667440dcb4a13974e (diff)
gentoo auto-resync : 05:10:2022 - 19:20:12
Diffstat (limited to 'games-puzzle/torrent/torrent-0.8.2-r2.ebuild')
-rw-r--r--games-puzzle/torrent/torrent-0.8.2-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-puzzle/torrent/torrent-0.8.2-r2.ebuild b/games-puzzle/torrent/torrent-0.8.2-r2.ebuild
new file mode 100644
index 000000000000..d2d71e4406b2
--- /dev/null
+++ b/games-puzzle/torrent/torrent-0.8.2-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop
+
+DESCRIPTION="Match rising tiles before reaching the top to score as many points as possible"
+HOMEPAGE="http://www.shiftygames.com/torrent/torrent.html"
+SRC_URI="http://www.shiftygames.com/torrent/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=media-libs/libsdl-1.2.4
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-image-1.2
+ media-libs/sdl-ttf
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.2-Fix-function-prototypes-inline-link-issue.patch
+)
+
+src_prepare() {
+ default
+
+ # Needed for Clang 16+ to flush out stale configure
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newicon pics/sg_icon.png ${PN}.png
+ make_desktop_entry ${PN} Torrent ${PN}
+}