summaryrefslogtreecommitdiff
path: root/games-puzzle/tod
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/tod
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/tod')
-rw-r--r--games-puzzle/tod/Manifest4
-rw-r--r--games-puzzle/tod/files/tod-0-makefile.patch13
-rw-r--r--games-puzzle/tod/metadata.xml8
-rw-r--r--games-puzzle/tod/tod-0-r1.ebuild37
4 files changed, 62 insertions, 0 deletions
diff --git a/games-puzzle/tod/Manifest b/games-puzzle/tod/Manifest
new file mode 100644
index 000000000000..5d5da4e54316
--- /dev/null
+++ b/games-puzzle/tod/Manifest
@@ -0,0 +1,4 @@
+AUX tod-0-makefile.patch 336 BLAKE2B 914b05d5bf298a3d60c6ac836ef45127c253859fa8b620adf5827abbc3dd3375c02eebd614ab79277bd3c52f7f383a4b4458e80d8fabd8549e4d49ca5702959f SHA512 efd342bfedacdb1dcd20d5a938a02c555c7d260bf9584a0d6d24c4aa0617df7ba8e37fdfacc5b0e0f600a2cae752e50347ba8b6992c5ba2dc22c1b62306e7438
+DIST wintod.zip 115653 BLAKE2B 9c54be567954892eabc353bf5985579ff11fcb9e00304bf92792ef787bbaccf29084c68a58faae46229856fae103c4b27c462b62c2da489bfe635d474fd564ef SHA512 8cc203d9745cc4855c58c2f9119d06a1f02e1ecb9c1cc2c1dc1f1c77e5aa0553925bdcba3d744db462bbc77f3637a42e35a579a8807c8098aa2fde7452cc30cc
+EBUILD tod-0-r1.ebuild 748 BLAKE2B a78c2a73d87c13263a8400df1312e2c9d02972d92a2882080a6801e1a7dac7c8bd6545ce8546bcbc31d8927888b4c09a673985316d4b637fa4cbca2f33f74071 SHA512 e3b4566e211a670b1fce84958e79d95dee9af188ce73ce415976fc835f44f77639b989e3c3c8ceaf8d6e1a768bd239364a1e14ca08d19171fd57ffe01e429612
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-puzzle/tod/files/tod-0-makefile.patch b/games-puzzle/tod/files/tod-0-makefile.patch
new file mode 100644
index 000000000000..9783fab0c4bc
--- /dev/null
+++ b/games-puzzle/tod/files/tod-0-makefile.patch
@@ -0,0 +1,13 @@
+--- a/makefile
++++ b/makefile
+@@ -1,8 +1,7 @@
+ OBJ = hiscore rec scrctl tetanus crc allegdlg hgrcos
+ HEADS = tod.h allegdlg.h crc.h hgrcos.h hiscore.h
+-LIBS = -lalleg
+-CFLAGS = -Wall -march=i486 -mcpu=i686 -O3 -ffast-math
+-LDFLAGS = -mwindows
++LIBS = `allegro-config --libs`
++CFLAGS += `allegro-config --cflags`
+ CC = gcc
+
+
diff --git a/games-puzzle/tod/metadata.xml b/games-puzzle/tod/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-puzzle/tod/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-puzzle/tod/tod-0-r1.ebuild b/games-puzzle/tod/tod-0-r1.ebuild
new file mode 100644
index 000000000000..0ed9a29063f0
--- /dev/null
+++ b/games-puzzle/tod/tod-0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Tetanus On Drugs simulates playing Tetris under the influence of drugs"
+HOMEPAGE="http://www.pineight.com/tod/"
+SRC_URI="http://www.pineight.com/pc/win${PN}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/allegro:0[X]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-makefile.patch
+ sed -i \
+ -e "s:idltd\.dat:/usr/share/${PN}/idltd.dat:" \
+ rec.c || die
+}
+
+src_install() {
+ newbin tod-debug.exe tod
+ insinto /usr/share/${PN}
+ doins idltd.dat
+ dodoc readme.txt
+ make_desktop_entry ${PN} "Tetanus On Drugs"
+}