summaryrefslogtreecommitdiff
path: root/games-puzzle/tod/tod-0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-puzzle/tod/tod-0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-puzzle/tod/tod-0.ebuild')
-rw-r--r--games-puzzle/tod/tod-0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-puzzle/tod/tod-0.ebuild b/games-puzzle/tod/tod-0.ebuild
new file mode 100644
index 000000000000..17121aad8296
--- /dev/null
+++ b/games-puzzle/tod/tod-0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Tetanus On Drugs simulates playing a Tetris clone under the influence of hallucinogenic drugs"
+HOMEPAGE="http://www.pineight.com/tod/"
+SRC_URI="http://www.pineight.com/pc/win${PN}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/allegro:0[X]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ sed -i \
+ -e "s:idltd\.dat:${GAMES_DATADIR}/${PN}/idltd.dat:" \
+ rec.c || die
+}
+
+src_install() {
+ newgamesbin tod-debug.exe tod
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins idltd.dat
+ dodoc readme.txt
+ prepgamesdirs
+}