summaryrefslogtreecommitdiff
path: root/games-puzzle/swell-foop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /games-puzzle/swell-foop
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'games-puzzle/swell-foop')
-rw-r--r--games-puzzle/swell-foop/Manifest2
-rw-r--r--games-puzzle/swell-foop/swell-foop-41.0.1.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/games-puzzle/swell-foop/Manifest b/games-puzzle/swell-foop/Manifest
index 6548c64a0c00..c38953398e7c 100644
--- a/games-puzzle/swell-foop/Manifest
+++ b/games-puzzle/swell-foop/Manifest
@@ -1,3 +1,5 @@
DIST swell-foop-40.1.tar.xz 821744 BLAKE2B 598af5d5bdeab2b6c3aca849e8c0a1f0c9690d14bc859c4c89bdf0577868efd7450f88e0039925e3cb83c60cd9943965382592962dc49fca31dac933099b7321 SHA512 99a90030eec32163f84e238458fca74b8ba19c7b804dc3f65d7f8f50f3d7f45dfd1cf45d383e332cad6c18fdf5d4eb79bf3c7b9f406a02431ed787b23a1c8cb7
+DIST swell-foop-41.0.1.tar.xz 758800 BLAKE2B 5df8870f5be52a4dfec9c012a2496e9b727eb93d01480bedb1c836b8b399f9b42ff36b18c78dad7ca26dd9da6b143229064167423fba3d7630a86d5108e4f3d2 SHA512 b579616cddb77fb3e6d6a8b382fe4b9692a884d62b0907fd551048dbfe28d3f031ac9c8e43e2888ee408a51bccb026109cd9e9ac371b475eaffebb1d9c237c11
EBUILD swell-foop-40.1.ebuild 873 BLAKE2B afb45ae03f89af2386f6bb030152574908ab204d97143c47878fd495abc011767f41cd34f977cf8e6158cff9fc30b774d2581e8074f76c56b5824043cca7a85f SHA512 61ccbf3ca403820c6cad19c2f2efbb4d46a278a2bc00821a8e077d899eabb32c7fcc0c7174e189d2e31aff086f13e8f312df48d20e03b130f0db1c0d04617f06
+EBUILD swell-foop-41.0.1.ebuild 875 BLAKE2B 128392d94d1c55ef80de58f5a2f6ee522e3f51682f8f6b08af6713829b46e56dfe6ea8b811e35f1156aab92ee45cc069e9ef0bafe0e659821f1779ee365354f6 SHA512 db4f1a4508a72e1a16f7fb76be9b8c18b9c2748454a4c96867829724a43df025bd9d1cd1b549b09e3449f5714b350098646bae2db6f1b8cbada005b33d6f34eb
MISC metadata.xml 250 BLAKE2B 8f7f0fe023d43e380e7861e897e6afcb5de4baefb42ea9c65a57dfc0d204c6f787a99295141832e732ebb08be218da56ba77e2dd9639e4e3aabf718ce4db1d0c SHA512 2684e772dd6d83e4b49f08f2ba22d8a0a753e7b46863489eff1b5d1f2f147ad80ffd93245ca405ac4c747249bc1b754454ec9865fe16da70f9b257051e105fd8
diff --git a/games-puzzle/swell-foop/swell-foop-41.0.1.ebuild b/games-puzzle/swell-foop/swell-foop-41.0.1.ebuild
new file mode 100644
index 000000000000..763530ce1aca
--- /dev/null
+++ b/games-puzzle/swell-foop/swell-foop-41.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Clear the screen by removing groups of colored and shaped tiles"
+HOMEPAGE="https://wiki.gnome.org/Apps/Swell%20Foop"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=x11-libs/gtk+-3.24:3
+ >=media-libs/clutter-1.14.0:1.0
+ >=media-libs/clutter-gtk-1.5.0:1.0
+ >=dev-libs/libgnome-games-support-1.7.1:1=
+ >=dev-libs/libgee-0.14.0:0.8=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}