summaryrefslogtreecommitdiff
path: root/games-puzzle/splice/splice-20121120-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-puzzle/splice/splice-20121120-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-puzzle/splice/splice-20121120-r1.ebuild')
-rw-r--r--games-puzzle/splice/splice-20121120-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/games-puzzle/splice/splice-20121120-r1.ebuild b/games-puzzle/splice/splice-20121120-r1.ebuild
new file mode 100644
index 000000000000..2a420c4413f1
--- /dev/null
+++ b/games-puzzle/splice/splice-20121120-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop wrapper
+
+DESCRIPTION="An experimental and artistic puzzler set in a microbial world"
+HOMEPAGE="http://www.cipherprime.com/games/splice/"
+SRC_URI="splice-linux-1353389454.tar.gz"
+S="${WORKDIR}"/Linux
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=opt/${PN}
+QA_PREBUILT="
+ ${MYGAMEDIR#/}/Splice*
+ ${MYGAMEDIR#/}/Splice_Data/Mono/*
+"
+
+# TODO: unbundle mono? (seems hardcoded)
+# icon
+RDEPEND="
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext"
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your DISTDIR directory."
+}
+
+src_prepare() {
+ default
+
+ einfo "Removing ${ARCH} unrelated files..."
+ rm -v Splice.x86$(usex amd64 "" "_64") || die
+ rm -rv Splice_Data/Mono/x86$(usex amd64 "" "_64") || die
+
+ rm README~ || die
+ mv README "${T}"/ || die
+}
+
+src_install() {
+ dodoc "${T}"/README
+
+ insinto ${MYGAMEDIR}
+ doins -r *
+
+ make_desktop_entry ${PN}
+ make_wrapper ${PN} "./Splice.x86$(usex amd64 "_64" "")" "${MYGAMEDIR}"
+
+ fperms +x ${MYGAMEDIR}/Splice.x86$(usex amd64 "_64" "")
+}