summaryrefslogtreecommitdiff
path: root/games-puzzle/quadra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/quadra
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/quadra')
-rw-r--r--games-puzzle/quadra/Manifest4
-rw-r--r--games-puzzle/quadra/files/quadra-1.2.0-format.patch11
-rw-r--r--games-puzzle/quadra/metadata.xml11
-rw-r--r--games-puzzle/quadra/quadra-1.2.0-r1.ebuild46
4 files changed, 72 insertions, 0 deletions
diff --git a/games-puzzle/quadra/Manifest b/games-puzzle/quadra/Manifest
new file mode 100644
index 000000000000..1c3b62b8f221
--- /dev/null
+++ b/games-puzzle/quadra/Manifest
@@ -0,0 +1,4 @@
+AUX quadra-1.2.0-format.patch 491 BLAKE2B 21341a7d0a6fa1556d9d79d3fa55f2cb1fc4cf6244dc8fbdc937acb9250bec258818ffd6644d1f40a5fc0db07e64555121f2d0ce5c9ef9ffeadf2da6ebe78412 SHA512 a0a05c3ced44a88d7766a0ef2053dce378df4e6cec74acc7d074a27bffc48d6c43977289e779bc526d730b9d5c8acc18c1cc46c865f3ea7de0a6226937a08ffe
+DIST quadra-1.2.0.tar.gz 5103875 BLAKE2B 7b0bce4e8be77de2e357cd14f60ebdbf3ef72f2262013954bca9a8d1a9a2833e00a0fe59f818b78603628999e7e1204c6974a5d9f74f4ea9bb288325d518744c SHA512 1c3e1020a584fa83595b7b183d5346f8e357ddef6b29c0b4a3797e2ace50c6e9ff14f132b8299ca582db739f4d699fa8ab94be93ef86e5a01389f958ce91e837
+EBUILD quadra-1.2.0-r1.ebuild 916 BLAKE2B 93ae5d77d1550e6093955fd293ee12ca3b794d8237ffe34d760e99192418a1e1a35c9a6e875be5d0e5810fb2592f5d1fbe04ccb1da4f394f5609bc176c3e1262 SHA512 0291db9fde214222cdea677e5a287c71d2186d7ee84579c7655a8c45acaaf4544f2cfd39d7372e1e9b29e0ff09ad1a2455095ef55ade8ce52d835528aa7e83cd
+MISC metadata.xml 329 BLAKE2B b57a9d305d40db5c2682878b7c26c6150bbcc7825c17169c9380a288b69aec71d51793dbf0071f157a8e03be1d90632d26227cffc6855982562d37b606982a1e SHA512 81750413c002a39166c0802840aac367a3b07f61a1c711bb68fdea6f8dff71f4689c24ccf75c61336f03ddea9993c45c5b869d2f3467540f4695a35da9a6438f
diff --git a/games-puzzle/quadra/files/quadra-1.2.0-format.patch b/games-puzzle/quadra/files/quadra-1.2.0-format.patch
new file mode 100644
index 000000000000..ca56f5b4cc00
--- /dev/null
+++ b/games-puzzle/quadra/files/quadra-1.2.0-format.patch
@@ -0,0 +1,11 @@
+--- a/source/net_list.cpp.old 2015-12-08 21:41:16.782404098 +0100
++++ b/source/net_list.cpp 2015-12-08 21:41:33.153114600 +0100
+@@ -693,7 +693,7 @@
+ //Drawn at a total higher or equal to end_value: suspense!
+ // or maybe timer just elapsed and the game is drawn
+ // (still suspense! :))
+- sprintf(st, ST_GAMETIED);
++ sprintf(st, "%s", ST_GAMETIED);
+ message(-1, st);
+ { Sfx stmp(sons.levelup, 0, 0, -1, 18050); }
+ { Sfx stmp(sons.levelup, 0, 0, -1, 18100); }
diff --git a/games-puzzle/quadra/metadata.xml b/games-puzzle/quadra/metadata.xml
new file mode 100644
index 000000000000..018874d4b550
--- /dev/null
+++ b/games-puzzle/quadra/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">quadra</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-puzzle/quadra/quadra-1.2.0-r1.ebuild b/games-puzzle/quadra/quadra-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..c811bb17564e
--- /dev/null
+++ b/games-puzzle/quadra/quadra-1.2.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A tetris clone with multiplayer support"
+HOMEPAGE="https://github.com/quadra-game/quadra"
+SRC_URI="https://github.com/${PN}-game/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXxf86vm
+ x11-libs/libXext
+ media-libs/libpng:0=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ sys-devel/bc
+ x11-base/xorg-proto
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "/^libgamesdir:=/s:/games:/${PN}:" \
+ -e "/^datagamesdir:=/s:/games:/${PN}:" \
+ config/config.mk.in || die
+ eapply "${FILESDIR}"/${P}-format.patch
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins ${PN}.res
+ doicon images/${PN}.xpm
+ make_desktop_entry ${PN} Quadra
+
+ HTML_DOCS="help/*" einstalldocs
+}