summaryrefslogtreecommitdiff
path: root/games-puzzle/pipepanic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/pipepanic
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/pipepanic')
-rw-r--r--games-puzzle/pipepanic/Manifest4
-rw-r--r--games-puzzle/pipepanic/files/pipepanic-0.1.3-gentoo.patch21
-rw-r--r--games-puzzle/pipepanic/metadata.xml8
-rw-r--r--games-puzzle/pipepanic/pipepanic-0.1.3-r1.ebuild39
4 files changed, 72 insertions, 0 deletions
diff --git a/games-puzzle/pipepanic/Manifest b/games-puzzle/pipepanic/Manifest
new file mode 100644
index 000000000000..422d4981cf64
--- /dev/null
+++ b/games-puzzle/pipepanic/Manifest
@@ -0,0 +1,4 @@
+AUX pipepanic-0.1.3-gentoo.patch 584 BLAKE2B 7a785fc5494f71c14d2298caa87168a52d695e3b5c450c6f1395b9dee8f911fd35e28d23db4c14b252e337b203727647a48c4113b0b6349289a7044ed3c4145f SHA512 0fef3b79063bcae38412679ce5644d8d119ba3a86b8a752234d97b7009044373f6cda8e983b53864f266e5c00203fb278c61fa44af432014b1aba5a402d41bab
+DIST pipepanic-0.1.3-source.tar.gz 232200 BLAKE2B 25a344d0a78196d8416d7da663e4400acfe010b6020c3b64764c1dcf6f07d7a434add6d5c2c607a17ca356eb67fb0c8572d72410ea8ca5df915f9802792400d9 SHA512 468f3194976c7030c2fa3d8f30eaa13cc25e0b04feeb48a5d1267d119eb991618bad14ddba0a8268e6b92f38f2a17bc5b119728b222b0ee50494807832ad2ab7
+EBUILD pipepanic-0.1.3-r1.ebuild 869 BLAKE2B 8b4700bf2865b09dcf6f865e8cafdb5c5af4143bc986743c995042ed4b7d8f6e2e19eeb947911ef2aa557f3541656421e00aa7b8b303e7959c4c77b1eec2f5a5 SHA512 f1e1fb22f5c701a5e0a488c3610ec44f5ff540eb4e5f75d83b8b227add221b1986bcf15f2754ac430cd6045690edb958974ab12bbc94121965bab04c924543ce
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-puzzle/pipepanic/files/pipepanic-0.1.3-gentoo.patch b/games-puzzle/pipepanic/files/pipepanic-0.1.3-gentoo.patch
new file mode 100644
index 000000000000..1366b7d341c8
--- /dev/null
+++ b/games-puzzle/pipepanic/files/pipepanic-0.1.3-gentoo.patch
@@ -0,0 +1,21 @@
+diff -ru pipepanic-0.1.3-source.orig/Makefile pipepanic-0.1.3-source/Makefile
+--- pipepanic-0.1.3-source.orig/Makefile 2006-05-16 16:11:29.000000000 -0400
++++ pipepanic-0.1.3-source/Makefile 2009-11-03 13:38:52.109137983 -0500
+@@ -3,15 +3,12 @@
+ TARGET=pipepanic
+
+ # Settings for x86.
+-CC=gcc
+-CFLAGS=-O2 -Wall -pedantic `sdl-config --cflags`
+-LINK=gcc
+-LDFLAGS=
++CFLAGS+=`sdl-config --cflags`
+ LIBS=`sdl-config --libs`
+
+ all:
+ $(CC) $(CFLAGS) -c $(SOURCES)
+- $(LINK) $(LDFLAGS) $(OBJECTS) $(LIBS) -o $(TARGET)
++ $(CC) $(LDFLAGS) $(OBJECTS) $(LIBS) -o $(TARGET)
+
+ .PHONY: clean
+
diff --git a/games-puzzle/pipepanic/metadata.xml b/games-puzzle/pipepanic/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-puzzle/pipepanic/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-puzzle/pipepanic/pipepanic-0.1.3-r1.ebuild b/games-puzzle/pipepanic/pipepanic-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..bc849e724279
--- /dev/null
+++ b/games-puzzle/pipepanic/pipepanic-0.1.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A simple pipe connecting game"
+HOMEPAGE="http://www.users.waitrose.com/~thunor/pipepanic/"
+SRC_URI="http://www.users.waitrose.com/~thunor/pipepanic/dload/${P}-source.tar.gz"
+
+LICENSE="GPL-2 FreeArt"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]"
+RDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}-source"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-gentoo.patch
+ # change harcoded data paths to match the install directory
+ sed -i \
+ -e "s:/opt/QtPalmtop/share/pipepanic/:/usr/share/${PN}/:" \
+ main.h \
+ || die "sed failed"
+}
+
+src_install() {
+ dobin "${PN}"
+
+ insinto "/usr/share/${PN}"
+ doins *.bmp
+ newicon PipepanicIcon64.png ${PN}.png
+ make_desktop_entry ${PN} "Pipepanic"
+ einstalldocs
+}