summaryrefslogtreecommitdiff
path: root/games-puzzle/pingus/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/pingus/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/pingus/files')
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch13
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch22
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-gcc7.patch21
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch10
4 files changed, 66 insertions, 0 deletions
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch b/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch
new file mode 100644
index 000000000000..ab772d8c72e9
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch
@@ -0,0 +1,13 @@
+# Work around Gentoo's crippled dash
+
+--- pingus-0.7.6/Makefile
++++ pingus-0.7.6/Makefile
+@@ -39,7 +39,7 @@
+ install -d "$(DESTDIR)$(BINDIR)"
+
+ install -D build/pingus "$(DESTDIR)$(BINDIR)/pingus.bin"
+- echo -e "#!/bin/sh\nexec \"$(BINDIR)/pingus.bin\" --datadir \"$(DATADIR)\"" > "$(DESTDIR)$(BINDIR)/pingus"
++ printf '%s\n%s' "#!/bin/sh" "exec \"$(BINDIR)/pingus.bin\" --datadir \"$(DATADIR)\"" > "$(DESTDIR)$(BINDIR)/pingus"
+ chmod 755 "$(DESTDIR)$(BINDIR)/pingus"
+
+ install-data:
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch b/games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch
new file mode 100644
index 000000000000..3c1cac5589e4
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch
@@ -0,0 +1,22 @@
+--- a/src/pingus/pingus_main.cpp
++++ b/src/pingus/pingus_main.cpp
+@@ -465,7 +465,7 @@
+ void
+ PingusMain::print_greeting_message()
+ {
+- std::string greeting = "Welcome to Pingus "VERSION;
++ std::string greeting = "Welcome to Pingus " VERSION;
+ greeting += "!";
+ std::cout << greeting << std::endl;
+ for (unsigned int i = 0; i < greeting.length(); ++i)
+--- a/src/pingus/screens/pingus_menu.cpp
++++ b/src/pingus/screens/pingus_menu.cpp
+@@ -153,7 +153,7 @@
+ gc.get_height()/2 - 280));
+
+ gc.print_left(Fonts::pingus_small, Vector2i(gc.get_width()/2 - 400 + 25, gc.get_height()-140),
+- "Pingus "VERSION" - Copyright (C) 1998-2011 Ingo Ruhnke <grumbel@gmail.com>\n"
++ "Pingus " VERSION " - Copyright (C) 1998-2011 Ingo Ruhnke <grumbel@gmail.com>\n"
+ "See the file AUTHORS for a complete list of contributors.\n"
+ "Pingus comes with ABSOLUTELY NO WARRANTY. This is free software, and you are\n"
+ "welcome to redistribute it under certain conditions; see the file COPYING for details.\n");
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-gcc7.patch b/games-puzzle/pingus/files/pingus-0.7.6-gcc7.patch
new file mode 100644
index 000000000000..bf04ccd047cc
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.6-gcc7.patch
@@ -0,0 +1,21 @@
+From df6e2f445d3e2925a94d22faeb17be9444513e92 Mon Sep 17 00:00:00 2001
+From: Jonathan Wakely <jwakely@redhat.com>
+Date: Mon, 30 Jan 2017 15:41:53 +0000
+Subject: [PATCH] Add missing header for std::function and std::bind
+
+---
+ src/pingus/screens/demo_session.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/pingus/screens/demo_session.cpp b/src/pingus/screens/demo_session.cpp
+index e3ec49a2c..f887e50f0 100644
+--- a/src/pingus/screens/demo_session.cpp
++++ b/src/pingus/screens/demo_session.cpp
+@@ -18,6 +18,7 @@
+
+ #include <algorithm>
+ #include <iostream>
++#include <functional>
+
+ #include "engine/gui/gui_manager.hpp"
+ #include "engine/gui/surface_button.hpp"
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch b/games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch
new file mode 100644
index 000000000000..6d1af794b032
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch
@@ -0,0 +1,10 @@
+--- a/src/engine/display/display.cpp
++++ b/src/engine/display/display.cpp
+@@ -28,6 +28,7 @@
+ #include "engine/display/delta/delta_framebuffer.hpp"
+ #include "engine/display/null_framebuffer.hpp"
+ #include "util/log.hpp"
++#include "util/raise_exception.hpp"
+
+ std::unique_ptr<Framebuffer> Display::s_framebuffer;
+