summaryrefslogtreecommitdiff
path: root/games-puzzle/magiccube4d/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-puzzle/magiccube4d/files
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/magiccube4d/files')
-rw-r--r--games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch53
-rw-r--r--games-puzzle/magiccube4d/files/magiccube4d-2.2-gcc41.patch22
-rw-r--r--games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch15
-rw-r--r--games-puzzle/magiccube4d/files/magiccube4d-EventHandler.patch11
4 files changed, 0 insertions, 101 deletions
diff --git a/games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch b/games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch
deleted file mode 100644
index 7fbd52871887..000000000000
--- a/games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -Nru magiccube4d-src-2_2.orig/EventHandler.cpp magiccube4d-src-2_2/EventHandler.cpp
---- magiccube4d-src-2_2.orig/EventHandler.cpp 2007-09-30 12:01:46.503967712 +0200
-+++ magiccube4d-src-2_2/EventHandler.cpp 2007-09-30 12:03:23.489172011 +0200
-@@ -20,6 +20,7 @@
- #include <iostream>
- #include <unistd.h>
- #include <stdio.h>
-+#include <stdint.h>
-
- #include "MagicCube.h"
- #include "Puzzlest.h"
-@@ -415,7 +416,7 @@
- void
- EventHandler::undo_cb(void* argp)
- {
-- int arg = (int) argp;
-+ int arg = (intptr_t) argp;
- struct stickerspec grip;
- int dir;
- int slicesmask;
-@@ -461,7 +462,7 @@
- void
- EventHandler::redo_cb(void* argp)
- {
-- int arg = (int) argp;
-+ int arg = (intptr_t) argp;
- struct stickerspec grip;
- int dir;
- int slicesmask;
-@@ -507,7 +508,7 @@
- void
- EventHandler::scramble_cb(void *arg = NULL)
- {
-- int n = (int)arg;
-+ int n = (intptr_t)arg;
- struct stickerspec grip;
- int i, previous_face = -1;
- int ngrips = NFACES * 3 * 3 * 3;
-@@ -855,12 +856,12 @@
- void
- EventHandler::newPuzzle_cb(void* arg)
- {
-- if ((int)arg == preferences.getLength())
-+ if ((intptr_t)arg == preferences.getLength())
- {
- reset_cb(0);
- return;
- }
-- preferences.setLength((int)arg);
-+ preferences.setLength((intptr_t)arg);
- int length = preferences.getLength();
-
- polymgr->reset(length);
diff --git a/games-puzzle/magiccube4d/files/magiccube4d-2.2-gcc41.patch b/games-puzzle/magiccube4d/files/magiccube4d-2.2-gcc41.patch
deleted file mode 100644
index 8e2aaf2b5fcd..000000000000
--- a/games-puzzle/magiccube4d/files/magiccube4d-2.2-gcc41.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/EventHandler.h.old 2006-05-19 22:11:48.000000000 +0200
-+++ b/EventHandler.h 2006-05-19 22:11:58.000000000 +0200
-@@ -165,7 +165,7 @@
-
- int number_of_reference_stickers_needed;
- int (*reference_stickers_needed)[4];
-- void (EventHandler::*what_to_do_after_got_reference_stickers) (void *arg = NULL);
-+ void (EventHandler::*what_to_do_after_got_reference_stickers) (void *arg);
- void* cur_ui_data;
-
- bool quick_mode;
---- a/Machine.h.old 2006-05-19 22:12:17.000000000 +0200
-+++ b/Machine.h 2006-05-19 22:12:29.000000000 +0200
-@@ -31,7 +31,7 @@
- {
- public:
- typedef void (EventHandler::*event_handler)(EventHandler::Event*,
-- void *arg = 0);
-+ void *arg);
- virtual ~Machine() {};
-
- static Machine* createMachine(EventHandler*, int& argc, char *argv[],
diff --git a/games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch b/games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch
deleted file mode 100644
index 73d1b4a59dca..000000000000
--- a/games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/Makefile.in.old 2010-10-15 10:38:48.000000000 +0200
-+++ b/Makefile.in 2010-10-15 10:39:07.000000000 +0200
-@@ -72,10 +72,10 @@
- $(CXX) -c $(CXXFLAGS) $<
-
- $(TARGET): $(OBJS)
-- $(CXX) -o $(TARGET) $(OBJS) $(LIBDIRS) $(LIBS)
-+ $(CXX) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBDIRS) $(LIBS)
-
- $(TARGET).static: $(OBJS)
-- $(CXX) -static -o $(TARGET).static $(OBJS) $(LIBDIRS) $(LIBS)
-+ $(CXX) $(LDFLAGS) -static -o $(TARGET).static $(OBJS) $(LIBDIRS) $(LIBS)
-
- Vec.h: vec_h.c
- $(CC) -o vec_h vec_h.c
diff --git a/games-puzzle/magiccube4d/files/magiccube4d-EventHandler.patch b/games-puzzle/magiccube4d/files/magiccube4d-EventHandler.patch
deleted file mode 100644
index d242438d8d05..000000000000
--- a/games-puzzle/magiccube4d/files/magiccube4d-EventHandler.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/EventHandler.cpp.old 2004-11-04 22:58:13.735812448 +1100
-+++ b/EventHandler.cpp 2004-11-04 22:57:03.176539088 +1100
-@@ -326,7 +326,7 @@
- number_of_reference_stickers_needed--;
- reference_stickers_needed++;
- if (number_of_reference_stickers_needed == 0)
-- (this->*what_to_do_after_got_reference_stickers)();
-+ (this->*what_to_do_after_got_reference_stickers)(NULL);
- }
- }
-