summaryrefslogtreecommitdiff
path: root/games-puzzle/lightsoff/lightsoff-40.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-puzzle/lightsoff/lightsoff-40.0.1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-puzzle/lightsoff/lightsoff-40.0.1.ebuild')
-rw-r--r--games-puzzle/lightsoff/lightsoff-40.0.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-puzzle/lightsoff/lightsoff-40.0.1.ebuild b/games-puzzle/lightsoff/lightsoff-40.0.1.ebuild
new file mode 100644
index 000000000000..211499a9c37f
--- /dev/null
+++ b/games-puzzle/lightsoff/lightsoff-40.0.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+inherit gnome.org gnome2-utils meson xdg vala
+
+DESCRIPTION="Turn off all the lights"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lightsoff"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=gnome-base/librsvg-2.32.0:2
+"
+DEPEND="${RDEPEND}"
+# libxml2:2 needed for glib-compile-resources xml-stripblanks attributes
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ gnome-base/librsvg:2[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+
+ # Bug #778845
+ sed -i \
+ -e 's:40\.rc:40~rc:' \
+ -e 's:40\.beta:40~beta:' \
+ -e 's:40\.alpha:40~alpha:' \
+ data/org.gnome.LightsOff.appdata.xml.in || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}