summaryrefslogtreecommitdiff
path: root/games-puzzle/jools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/jools
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/jools')
-rw-r--r--games-puzzle/jools/Manifest4
-rw-r--r--games-puzzle/jools/jools-0.20-r3.ebuild55
-rw-r--r--games-puzzle/jools/metadata.xml15
3 files changed, 74 insertions, 0 deletions
diff --git a/games-puzzle/jools/Manifest b/games-puzzle/jools/Manifest
new file mode 100644
index 000000000000..b082e4e04e8a
--- /dev/null
+++ b/games-puzzle/jools/Manifest
@@ -0,0 +1,4 @@
+DIST jools-0.20.tar.gz 1710143 BLAKE2B 715c8be3e1e223cc5e8b8e6a0dfb0655c25bdd713bf5df678482063a6f68178449354f984b2ef0e52268379936e217786d0be7952ac2083f936d9bfe3551eca3 SHA512 11eadceb8208a72846a9e16a2dae0a1b1d7f8995d5ff2487ee03dd62811f3a232c0d08dc044c351f44c120e6e75eba11df1a727a9d5c6c57ce5e2ef8ee4d0986
+DIST jools-musicpack-1.0.tar.gz 4447501 BLAKE2B 2786a30d8a6cd09a05f1d13963b2c5f232b8d7c7c94bf83a5dc13979fc62349b9385bac1f08c2288e73134e38f78ef9bd48d84b4849f22c9ac791059be3b721b SHA512 1773beb8cd7df756cb4f7ba55729a6dfa995ca860f3381e2fed3884f42227d19955e13f8be9b2f6f64d4d86e452be9fe876963e24c85cd2c3cc42df62804b9c2
+EBUILD jools-0.20-r3.ebuild 1242 BLAKE2B c0db451dc3fad43264e5212de8ef3db07af83d4b939ba5c387fe8aa76aaedc0dda3af9b6681f86862794aa27c6c44fb286169fb90fcfd1a26a64eaec1137481d SHA512 578d076e12e0e71e9873b90bf0b5edfb9cf5e1beeb227ebd0238a40ec4bb7cb23d78b8395da9753d21690a44a5a6d584564be71ae37c1446175d33276276fd4c
+MISC metadata.xml 671 BLAKE2B 3d2b8089c8988076718719b26c9e0678ee0197297e72653baf5011a6a45a65bf210e0dababf5a17a254858af8c73155fad6d5cdde684c71169c76338e5630f9a SHA512 928c0217e8ef9222cee84694ef0da21cb7fa50bc190361979c4eb44e01081b49e805e441128baddfb13269b7a8f02f991cc4cb08b253cc1a475859d393f786c6
diff --git a/games-puzzle/jools/jools-0.20-r3.ebuild b/games-puzzle/jools/jools-0.20-r3.ebuild
new file mode 100644
index 000000000000..e70ad0267d87
--- /dev/null
+++ b/games-puzzle/jools/jools-0.20-r3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+MUS_P="${PN}-musicpack-1.0"
+DESCRIPTION="clone of Bejeweled, a popular pattern-matching game"
+HOMEPAGE="http://pessimization.com/software/jools/"
+SRC_URI="http://pessimization.com/software/jools/${P}.tar.gz
+ http://pessimization.com/software/jools/${MUS_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}/jools"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"/music
+ unpack ${MUS_P}.tar.gz
+}
+
+src_prepare() {
+ default
+ echo "MEDIAROOT = \"/usr/share/${PN}\"" > config.py
+ python_fix_shebang .
+}
+
+src_install() {
+ make_wrapper ${PN} "${EPYTHON} ./__init__.py" /usr/"$(get_libdir)"/${PN}
+ insinto /usr/"$(get_libdir)"/${PN}
+ doins *.py
+ python_optimize "${ED}/usr/$(get_libdir)/${PN}"
+
+ insinto /usr/share/${PN}
+ doins -r fonts images music sounds
+
+ newicon images/ruby/0001.png ${PN}.png
+ make_desktop_entry ${PN} Jools
+
+ dodoc ../{ChangeLog,doc/{POINTS,TODO}}
+ HTML_DOCS="../doc/manual.html" einstalldocs
+}
diff --git a/games-puzzle/jools/metadata.xml b/games-puzzle/jools/metadata.xml
new file mode 100644
index 000000000000..5e917c0945b8
--- /dev/null
+++ b/games-puzzle/jools/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription lang="en">
+Jools is a graphical puzzle game in the tradition of Tetris. It has begun as
+a clone of Bejeweled, which is currently available for Windows, Mac, and
+Palm/Pocket PC devices. In a nutshell, the goal is to swap adjacent jools
+(jewels) within a grid, in order to create rows of three or more of a kind.
+These jools will then disappear, and more will fall to fill their places.
+</longdescription>
+</pkgmetadata>