summaryrefslogtreecommitdiff
path: root/games-puzzle/gnome2048/gnome2048-3.38.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-puzzle/gnome2048/gnome2048-3.38.2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-puzzle/gnome2048/gnome2048-3.38.2.ebuild')
-rw-r--r--games-puzzle/gnome2048/gnome2048-3.38.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-puzzle/gnome2048/gnome2048-3.38.2.ebuild b/games-puzzle/gnome2048/gnome2048-3.38.2.ebuild
new file mode 100644
index 000000000000..6e94bd1f38df
--- /dev/null
+++ b/games-puzzle/gnome2048/gnome2048-3.38.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="gnome-2048"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Move the tiles until you obtain the 2048 tile"
+HOMEPAGE="https://wiki.gnome.org/Apps/2048"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.42.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=media-libs/clutter-1.12.0:1.0
+ >=media-libs/clutter-gtk-1.6.0:1.0
+ >=dev-libs/libgee-0.14.0:0.8
+ >=dev-libs/libgnome-games-support-1.7.1:1=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}