summaryrefslogtreecommitdiff
path: root/games-puzzle/gnome-sudoku/gnome-sudoku-40.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /games-puzzle/gnome-sudoku/gnome-sudoku-40.2.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'games-puzzle/gnome-sudoku/gnome-sudoku-40.2.ebuild')
-rw-r--r--games-puzzle/gnome-sudoku/gnome-sudoku-40.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-puzzle/gnome-sudoku/gnome-sudoku-40.2.ebuild b/games-puzzle/gnome-sudoku/gnome-sudoku-40.2.ebuild
new file mode 100644
index 000000000000..b284e4ecdf62
--- /dev/null
+++ b/games-puzzle/gnome-sudoku/gnome-sudoku-40.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..10} )
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Test your logic skills in this number grid puzzle"
+HOMEPAGE="https://wiki.gnome.org/Apps/Sudoku"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ dev-libs/libgee:0.8=[introspection]
+ >=x11-libs/gtk+-3.24.0:3[introspection]
+ dev-libs/json-glib
+ >=dev-libs/qqwing-1.3.4
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}