summaryrefslogtreecommitdiff
path: root/games-puzzle/construo/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/construo/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/construo/files')
-rw-r--r--games-puzzle/construo/files/construo-0.2.2-gcc43.patch82
-rw-r--r--games-puzzle/construo/files/construo-0.2.2-lGLU.patch18
2 files changed, 100 insertions, 0 deletions
diff --git a/games-puzzle/construo/files/construo-0.2.2-gcc43.patch b/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
new file mode 100644
index 000000000000..48165ed21df0
--- /dev/null
+++ b/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
@@ -0,0 +1,82 @@
+--- a/command_line.cxx
++++ b/command_line.cxx
+@@ -19,7 +19,9 @@
+
+ #include <config.h>
+ #include <iostream>
+-#include <stdio.h>
++#include <cstdio>
++#include <cstdlib>
++#include <cstring>
+ #include "settings.hxx"
+ #include "command_line.hxx"
+
+--- a/config.hxx
++++ b/config.hxx
+@@ -21,6 +21,7 @@
+ #define CONFIG_HH
+
+ #include <string>
++#include <cstdlib>
+
+ class Config
+ {
+--- a/lisp_reader.cxx
++++ b/lisp_reader.cxx
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <cstring>
+ #include "construo_error.hxx"
+ #include "lisp_reader.hxx"
+
+--- a/unix_system.cxx
++++ b/unix_system.cxx
+@@ -17,8 +17,9 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-#include <stdio.h>
+-#include <assert.h>
++#include <cstdio>
++#include <cassert>
++#include <cstring>
+ #include <unistd.h>
+ #include <sys/time.h>
+ #include <time.h>
+--- a/vector.cxx
++++ b/vector.cxx
+@@ -16,8 +16,8 @@
+ totally replaced old CL_Vector with this code
+ */
+
+-#include <assert.h>
+-#include <math.h>
++#include <cassert>
++#include <cmath>
+ #include "vector.hxx"
+
+ CL_Vector::CL_Vector(float x, float y, float z, float w)
+--- a/world.cxx
++++ b/world.cxx
+@@ -17,7 +17,8 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-#include <assert.h>
++#include <cassert>
++#include <cstring>
+ #include <algorithm>
+ #include "config.h"
+
+--- a/x11_display.cxx
++++ b/x11_display.cxx
+@@ -19,6 +19,7 @@
+
+ #include <config.h>
+ #include <iostream>
++#include <cstring>
+ #include <X11/Xutil.h>
+ #include <X11/cursorfont.h>
+ #include <X11/keysym.h>
diff --git a/games-puzzle/construo/files/construo-0.2.2-lGLU.patch b/games-puzzle/construo/files/construo-0.2.2-lGLU.patch
new file mode 100644
index 000000000000..be8e7b604d6f
--- /dev/null
+++ b/games-puzzle/construo/files/construo-0.2.2-lGLU.patch
@@ -0,0 +1,18 @@
+--- a/configure.ac.old 2009-11-24 18:27:48.000000000 +0100
++++ b/configure.ac 2009-11-24 18:28:29.000000000 +0100
+@@ -114,7 +114,7 @@
+ AC_CHECK_LIB(glut, glutMainLoop,
+ [
+ ConstruoTargets="$ConstruoTargets construo.glut"
+- AC_SUBST(glut_LIBS,"-lglut")
++ AC_SUBST(glut_LIBS,"-lglut -lGLU -lGL -lm")
+ ],
+ [])
+
+@@ -158,4 +158,4 @@
+ echo " Ingo Ruhnke <grumbel@gmx.de>"
+ echo ""
+
+-# EOF #
+\ No newline at end of file
++# EOF #