summaryrefslogtreecommitdiff
path: root/games-puzzle/construo/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /games-puzzle/construo/files
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'games-puzzle/construo/files')
-rw-r--r--games-puzzle/construo/files/construo-0.2.2-gcc43.patch82
-rw-r--r--games-puzzle/construo/files/construo-0.2.2-lGLU.patch18
-rw-r--r--games-puzzle/construo/files/construo-0.2.3-clang.patch50
3 files changed, 50 insertions, 100 deletions
diff --git a/games-puzzle/construo/files/construo-0.2.2-gcc43.patch b/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
deleted file mode 100644
index 48165ed21df0..000000000000
--- a/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
+++ /dev/null
@@ -1,82 +0,0 @@
---- a/command_line.cxx
-+++ b/command_line.cxx
-@@ -19,7 +19,9 @@
-
- #include <config.h>
- #include <iostream>
--#include <stdio.h>
-+#include <cstdio>
-+#include <cstdlib>
-+#include <cstring>
- #include "settings.hxx"
- #include "command_line.hxx"
-
---- a/config.hxx
-+++ b/config.hxx
-@@ -21,6 +21,7 @@
- #define CONFIG_HH
-
- #include <string>
-+#include <cstdlib>
-
- class Config
- {
---- a/lisp_reader.cxx
-+++ b/lisp_reader.cxx
-@@ -17,6 +17,7 @@
- // along with this program; if not, write to the Free Software
- // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-
-+#include <cstring>
- #include "construo_error.hxx"
- #include "lisp_reader.hxx"
-
---- a/unix_system.cxx
-+++ b/unix_system.cxx
-@@ -17,8 +17,9 @@
- // along with this program; if not, write to the Free Software
- // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-
--#include <stdio.h>
--#include <assert.h>
-+#include <cstdio>
-+#include <cassert>
-+#include <cstring>
- #include <unistd.h>
- #include <sys/time.h>
- #include <time.h>
---- a/vector.cxx
-+++ b/vector.cxx
-@@ -16,8 +16,8 @@
- totally replaced old CL_Vector with this code
- */
-
--#include <assert.h>
--#include <math.h>
-+#include <cassert>
-+#include <cmath>
- #include "vector.hxx"
-
- CL_Vector::CL_Vector(float x, float y, float z, float w)
---- a/world.cxx
-+++ b/world.cxx
-@@ -17,7 +17,8 @@
- // along with this program; if not, write to the Free Software
- // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-
--#include <assert.h>
-+#include <cassert>
-+#include <cstring>
- #include <algorithm>
- #include "config.h"
-
---- a/x11_display.cxx
-+++ b/x11_display.cxx
-@@ -19,6 +19,7 @@
-
- #include <config.h>
- #include <iostream>
-+#include <cstring>
- #include <X11/Xutil.h>
- #include <X11/cursorfont.h>
- #include <X11/keysym.h>
diff --git a/games-puzzle/construo/files/construo-0.2.2-lGLU.patch b/games-puzzle/construo/files/construo-0.2.2-lGLU.patch
deleted file mode 100644
index be8e7b604d6f..000000000000
--- a/games-puzzle/construo/files/construo-0.2.2-lGLU.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/configure.ac.old 2009-11-24 18:27:48.000000000 +0100
-+++ b/configure.ac 2009-11-24 18:28:29.000000000 +0100
-@@ -114,7 +114,7 @@
- AC_CHECK_LIB(glut, glutMainLoop,
- [
- ConstruoTargets="$ConstruoTargets construo.glut"
-- AC_SUBST(glut_LIBS,"-lglut")
-+ AC_SUBST(glut_LIBS,"-lglut -lGLU -lGL -lm")
- ],
- [])
-
-@@ -158,4 +158,4 @@
- echo " Ingo Ruhnke <grumbel@gmx.de>"
- echo ""
-
--# EOF #
-\ No newline at end of file
-+# EOF #
diff --git a/games-puzzle/construo/files/construo-0.2.3-clang.patch b/games-puzzle/construo/files/construo-0.2.3-clang.patch
new file mode 100644
index 000000000000..abc812e9eb80
--- /dev/null
+++ b/games-puzzle/construo/files/construo-0.2.3-clang.patch
@@ -0,0 +1,50 @@
+Fix FTBFS with clang
+
+diff --git a/src/construo.hpp b/src/construo.hpp
+index fb77e3e..41aa650 100644
+--- a/src/construo.hpp
++++ b/src/construo.hpp
+@@ -19,7 +19,7 @@
+
+ #include <config.h>
+
+-#define CONSTRUO_DATADIR DATADIR"/games/"PACKAGE
++#define CONSTRUO_DATADIR DATADIR "/games/" PACKAGE
+
+ class SystemContext;
+ class InputContext;
+diff --git a/src/command_line.cpp b/src/command_line.cpp
+index df4669b..824a947 100644
+--- a/src/command_line.cpp
++++ b/src/command_line.cpp
+@@ -118,7 +118,7 @@ CommandLine::parse (int argc, char** argv)
+ void
+ CommandLine::print_help ()
+ {
+- std::cout << "Construo "VERSION"\n\n"
++ std::cout << "Construo " VERSION "\n\n"
+ << "Usage: construo [OPTIONS] [FILENAME]\n\n"
+ << " -h, --help display this help text\n"
+ << " -v,--version Print version number of the programm\n"
+@@ -135,7 +135,7 @@ CommandLine::print_help ()
+ void
+ CommandLine::print_version ()
+ {
+- std::cout << "Construo "VERSION"\n"
++ std::cout << "Construo " VERSION "\n"
+ << "Written by Ingo Ruhnke <grumbel@gmx.de>\n\n"
+ << "Copyright (C) 2002 Ingo Ruhnke <grumbel@gmx.de>\n"
+ << "This is free software; see the source for copying conditions. There is NO\n"
+diff --git a/src/world_gui_manager.cpp b/src/world_gui_manager.cpp
+index 9c6a5f4..4a7cef0 100644
+--- a/src/world_gui_manager.cpp
++++ b/src/world_gui_manager.cpp
+@@ -273,7 +273,7 @@ WorldGUIManager::draw_overlay ()
+ graphic_context->draw_string (410, bottom_line, "Zoom: ");
+ graphic_context->draw_string (480, bottom_line, to_string(WorldViewComponent::instance()->get_zoom()));
+
+- graphic_context->draw_string (610, bottom_line, "..:: Construo V"VERSION" ::..");
++ graphic_context->draw_string (610, bottom_line, "..:: Construo V" VERSION " ::..");
+ //graphic_context->draw_string (680, bottom_line, to_string(WorldViewComponent::instance()->get_zoom()));
+ }
+