summaryrefslogtreecommitdiff
path: root/games-puzzle/construo/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-puzzle/construo/files
reinit the tree, so we can have metadata
Diffstat (limited to 'games-puzzle/construo/files')
-rw-r--r--games-puzzle/construo/files/construo-0.2.2-gcc43.patch82
-rw-r--r--games-puzzle/construo/files/construo-0.2.2-lGLU.patch18
2 files changed, 100 insertions, 0 deletions
diff --git a/games-puzzle/construo/files/construo-0.2.2-gcc43.patch b/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
new file mode 100644
index 000000000000..cc946b043bae
--- /dev/null
+++ b/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
@@ -0,0 +1,82 @@
+--- command_line.cxx
++++ command_line.cxx
+@@ -19,7 +19,9 @@
+
+ #include <config.h>
+ #include <iostream>
+-#include <stdio.h>
++#include <cstdio>
++#include <cstdlib>
++#include <cstring>
+ #include "settings.hxx"
+ #include "command_line.hxx"
+
+--- config.hxx
++++ config.hxx
+@@ -21,6 +21,7 @@
+ #define CONFIG_HH
+
+ #include <string>
++#include <cstdlib>
+
+ class Config
+ {
+--- lisp_reader.cxx
++++ lisp_reader.cxx
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <cstring>
+ #include "construo_error.hxx"
+ #include "lisp_reader.hxx"
+
+--- unix_system.cxx
++++ unix_system.cxx
+@@ -17,8 +17,9 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-#include <stdio.h>
+-#include <assert.h>
++#include <cstdio>
++#include <cassert>
++#include <cstring>
+ #include <unistd.h>
+ #include <sys/time.h>
+ #include <time.h>
+--- vector.cxx
++++ vector.cxx
+@@ -16,8 +16,8 @@
+ totally replaced old CL_Vector with this code
+ */
+
+-#include <assert.h>
+-#include <math.h>
++#include <cassert>
++#include <cmath>
+ #include "vector.hxx"
+
+ CL_Vector::CL_Vector(float x, float y, float z, float w)
+--- world.cxx
++++ world.cxx
+@@ -17,7 +17,8 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-#include <assert.h>
++#include <cassert>
++#include <cstring>
+ #include <algorithm>
+ #include "config.h"
+
+--- x11_display.cxx
++++ x11_display.cxx
+@@ -19,6 +19,7 @@
+
+ #include <config.h>
+ #include <iostream>
++#include <cstring>
+ #include <X11/Xutil.h>
+ #include <X11/cursorfont.h>
+ #include <X11/keysym.h>
diff --git a/games-puzzle/construo/files/construo-0.2.2-lGLU.patch b/games-puzzle/construo/files/construo-0.2.2-lGLU.patch
new file mode 100644
index 000000000000..4c0b018cfdc1
--- /dev/null
+++ b/games-puzzle/construo/files/construo-0.2.2-lGLU.patch
@@ -0,0 +1,18 @@
+--- configure.ac.old 2009-11-24 18:27:48.000000000 +0100
++++ configure.ac 2009-11-24 18:28:29.000000000 +0100
+@@ -114,7 +114,7 @@
+ AC_CHECK_LIB(glut, glutMainLoop,
+ [
+ ConstruoTargets="$ConstruoTargets construo.glut"
+- AC_SUBST(glut_LIBS,"-lglut")
++ AC_SUBST(glut_LIBS,"-lglut -lGLU -lGL -lm")
+ ],
+ [])
+
+@@ -158,4 +158,4 @@
+ echo " Ingo Ruhnke <grumbel@gmx.de>"
+ echo ""
+
+-# EOF #
+\ No newline at end of file
++# EOF #