summaryrefslogtreecommitdiff
path: root/games-puzzle/braid-gog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-28 06:30:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-28 06:30:54 +0000
commit72fd2b48b7154274a1d2009cdaab54e7f49fb3aa (patch)
tree9c6ce981e8f924eb5f24e71e13c91b37aafb8616 /games-puzzle/braid-gog
parent721e451ec418e1712f6962404e111f0ebd487389 (diff)
gentoo auto-resync : 28:12:2024 - 06:30:54
Diffstat (limited to 'games-puzzle/braid-gog')
-rw-r--r--games-puzzle/braid-gog/Manifest4
-rw-r--r--games-puzzle/braid-gog/braid-gog-2.0.0.3-r1.ebuild84
-rw-r--r--games-puzzle/braid-gog/braid-gog-2.0.0.3.ebuild55
-rw-r--r--games-puzzle/braid-gog/metadata.xml3
4 files changed, 89 insertions, 57 deletions
diff --git a/games-puzzle/braid-gog/Manifest b/games-puzzle/braid-gog/Manifest
index baec12bcade4..98ea310707ae 100644
--- a/games-puzzle/braid-gog/Manifest
+++ b/games-puzzle/braid-gog/Manifest
@@ -1,3 +1,3 @@
DIST gog_braid_2.0.0.3.sh 122931560 BLAKE2B a15dde4a56510613d7104126c1f275ff17f07a246fc3f09cd2df26b870488c4b4e81a32f7505fc3b720f503f252ac00259aa7225b25c804af64bcced24c81bec SHA512 a7cccb0135e359e5bd7e0499fa449ff1e57c00a648aba37a5df7a12ec5a2a6d3b1758af7a168aec562c83bde864fa6cbbe2504b8a334bab01f6b209a8e4aadc6
-EBUILD braid-gog-2.0.0.3.ebuild 1204 BLAKE2B 9634e85ec51f87ad55bf734194c07c6434d693c4239f3ec339a3a38ee4186ba1a5e244b5f4f2cd2474bd018dd5d9b579a739d1cf8817629ffe00e1c3a3236c8f SHA512 8b28e7ff01e83e37421d95c1c3cfe4d33cf3312cde8ec8ffb863d9da7164c69796b17ade9891643cc8c93dd6fd73ecc1a0a1b07fa1baa3298bdad1d8226b305f
-MISC metadata.xml 254 BLAKE2B 4e6c8e1f126f76233a38aba6f5388488656795cb1d7d4767ccb1349772f5e78d59fc5663d4f1933dbe4633c2fbb90cd1d42d4b4d4f5ededc53653e7df13c7187 SHA512 2b82da849e3b0dec378f3fb497014f5d1dbc7aceb8a1f9d1638e83fe69448b1c5151eb4b1187154d828e4a296609ce5125b40977b2581d95b5588e353ca75135
+EBUILD braid-gog-2.0.0.3-r1.ebuild 1887 BLAKE2B 63555ec03ddd6f87de406d687c41fc56510c779819b9bbfe30c5ee51a70048a7f3c159cb2d956a1fa1e6b96413d8fe7789e9fadbaaa6485a1c535195dfe99a0b SHA512 f84e78d5271af658184b70874605c2cf0dc882a22427a81929243ef5ef5d768b73bb126325763c19d04457bfca30011f87460151eae7626645d9aa6fae9f10a5
+MISC metadata.xml 357 BLAKE2B 8b68058c32249f454cc8a320e08646437c7f6c63ea513b06ef86e1083f5a6dd9a301bc71ecd7cb684d8abf677389e2521239108575cbe1937b00769af4547a83 SHA512 fcc165f156a3089862f0cc5db9f6b8eabe4efcecf42638775e884a1f213b39b35c5c92f842efd6b9fd000157edff391d98cca878622a490d1dbee708f9f1526a
diff --git a/games-puzzle/braid-gog/braid-gog-2.0.0.3-r1.ebuild b/games-puzzle/braid-gog/braid-gog-2.0.0.3-r1.ebuild
new file mode 100644
index 000000000000..29f625d647fb
--- /dev/null
+++ b/games-puzzle/braid-gog/braid-gog-2.0.0.3-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg
+
+MY_PN="braid"
+DESCRIPTION="Platform game where you manipulate flow of time"
+HOMEPAGE="https://www.gog.com/en/game/braid"
+SRC_URI="gog_${MY_PN}_${PV}.sh"
+S="${WORKDIR}/data/noarch/game"
+
+LICENSE="GOG-EULA Arphic CC-BY-NC-SA-1.0"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="launcher"
+RESTRICT="bindist fetch splitdebug"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+RDEPEND="
+ !${CATEGORY}/${MY_PN}-hb
+ media-gfx/nvidia-cg-toolkit[abi_x86_32]
+ media-libs/libsdl2[joystick,opengl,sound,video,abi_x86_32]
+ virtual/opengl[abi_x86_32]
+ launcher? (
+ media-libs/fontconfig:1.0[abi_x86_32]
+ x11-libs/libX11[abi_x86_32]
+ x11-libs/libXcursor[abi_x86_32]
+ x11-libs/libXext[abi_x86_32]
+ x11-libs/libXfixes[abi_x86_32]
+ x11-libs/libXft[abi_x86_32]
+ x11-libs/libXinerama[abi_x86_32]
+ )
+"
+
+DIR="/opt/${MY_PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"
+ insinto "${DIR}"
+
+ doexe Braid.bin.x86
+ doins -r data Icon.bmp
+ dodoc READ_ME.txt
+
+ if use launcher; then
+ doexe launcher.bin.x86
+ exeinto "${DIR}"/lib
+ doexe lib/libfltk.so.1.3
+ dosym "../..${DIR}/launcher.bin.x86" /usr/bin/${MY_PN}
+ else
+ dosym "../..${DIR}/Braid.bin.x86" /usr/bin/${MY_PN}
+ fi
+
+ newicon -s 256 Icon.png ${MY_PN}.png
+ make_desktop_entry ${MY_PN} Braid
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if ! use launcher; then
+ elog "You have disabled the launcher. The game will run fullscreen with"
+ elog "Vsync and postprocessing enabled at an optimal framerate by default."
+ elog "Pass these options to change that:"
+ elog ""
+ elog " -windowed -width [X] -height [Y] -no_vsync -no_post -[R]fps"
+ fi
+}
diff --git a/games-puzzle/braid-gog/braid-gog-2.0.0.3.ebuild b/games-puzzle/braid-gog/braid-gog-2.0.0.3.ebuild
deleted file mode 100644
index 487d6adc7a25..000000000000
--- a/games-puzzle/braid-gog/braid-gog-2.0.0.3.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit desktop unpacker wrapper xdg
-
-MY_PN="braid"
-DESCRIPTION="Platform game where you manipulate flow of time"
-HOMEPAGE="https://www.gog.com/en/game/braid"
-SRC_URI="gog_${MY_PN}_${PV}.sh"
-
-LICENSE="GOG-EULA Arphic CC-BY-NC-SA-1.0"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-RESTRICT="bindist fetch splitdebug"
-
-BDEPEND="
- app-arch/unzip
-"
-
-RDEPEND="
- media-gfx/nvidia-cg-toolkit[abi_x86_32]
- media-libs/libsdl2[joystick,opengl,sound,video,abi_x86_32]
- virtual/opengl[abi_x86_32]
- x11-libs/fltk:1[abi_x86_32]
- x11-libs/libX11[abi_x86_32]
- !${CATEGORY}/${MY_PN}-hb
-"
-
-S="${WORKDIR}/data/noarch/game"
-DIR="/opt/${MY_PN}"
-QA_PREBUILT="${DIR#/}/*"
-
-pkg_nofetch() {
- einfo "Please buy and download ${SRC_URI} from:"
- einfo " ${HOMEPAGE}"
- einfo "and move it to your distfiles directory."
-}
-
-src_unpack() {
- unpack_zip ${A}
-}
-
-src_install() {
- exeinto "${DIR}"
- insinto "${DIR}"
-
- doexe {Braid,launcher}.bin.x86
- doins -r data Icon.*
- dodoc READ_ME.txt
-
- make_wrapper ${MY_PN} ./launcher.bin.x86 "${DIR}" /usr/$(ABI=x86 get_libdir)/fltk
- make_desktop_entry ${MY_PN} Braid "${EPREFIX}${DIR}"/Icon.png
-}
diff --git a/games-puzzle/braid-gog/metadata.xml b/games-puzzle/braid-gog/metadata.xml
index 7c730d47817a..9628757c45f0 100644
--- a/games-puzzle/braid-gog/metadata.xml
+++ b/games-puzzle/braid-gog/metadata.xml
@@ -5,4 +5,7 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+ <use>
+ <flag name="launcher">Install FLTK-based launcher that you probably don't need</flag>
+ </use>
</pkgmetadata>