summaryrefslogtreecommitdiff
path: root/games-puzzle/bff-or-die
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /games-puzzle/bff-or-die
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'games-puzzle/bff-or-die')
-rw-r--r--games-puzzle/bff-or-die/Manifest3
-rw-r--r--games-puzzle/bff-or-die/bff-or-die-20200614.ebuild51
-rw-r--r--games-puzzle/bff-or-die/metadata.xml8
3 files changed, 62 insertions, 0 deletions
diff --git a/games-puzzle/bff-or-die/Manifest b/games-puzzle/bff-or-die/Manifest
new file mode 100644
index 000000000000..41ff81201390
--- /dev/null
+++ b/games-puzzle/bff-or-die/Manifest
@@ -0,0 +1,3 @@
+DIST BffOrDie_Linux.zip 194773335 BLAKE2B a32d6b26e446d84110db13340d527ad1ccc423ddb1dfcdacabaf80c0b326f7c7c3d8315b26cc3a8cf4c403b4943e94cd954c77d01edc1963e4fc3b773a4f1042 SHA512 4767fea4c3a94fcf4ad6ca2a313ba1c10d9e6d0d593a63aa336f90f38599f1c43064f56c3e8fd18615ff08bd01dbc0cabe0bd01a798276075c160143f6102650
+EBUILD bff-or-die-20200614.ebuild 1195 BLAKE2B 4abecb0838a6b8365b0b33f35e310bac6bb0c939ec7780cdaef946f63360fa3d8cae67602cf28171a8e9e31d0db90abea100e288d7f1803e28b01ea01ee28a7a SHA512 e1d5cc3f4bd2ecbe3479d1b678756d9a8e39d8428203d73c181de1ba97cb0e6609d6eaa27e07d57a9c5948d4d9a9a5d06c61e3a5cf7a98493edc38288ff792a0
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-puzzle/bff-or-die/bff-or-die-20200614.ebuild b/games-puzzle/bff-or-die/bff-or-die-20200614.ebuild
new file mode 100644
index 000000000000..1f5014cfab27
--- /dev/null
+++ b/games-puzzle/bff-or-die/bff-or-die-20200614.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop xdg
+
+MY_PN="BffOrDie"
+DESCRIPTION="Time travelling alien couch co-op puzzle game for 1-4 players"
+HOMEPAGE="https://www.bffordie.com/"
+SRC_URI="${MY_PN}_Linux.zip"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ sys-libs/zlib
+ virtual/opengl
+"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+S="${WORKDIR}/${MY_PN}_Linux"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://asa-studio.itch.io/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+ exeinto "${DIR}"
+ newexe ${MY_PN}.$(usex amd64 x86_64 x86) ${MY_PN}
+ make_wrapper ${PN} "${DIR}"/${MY_PN}
+
+ insinto "${DIR}"
+ doins -r ${MY_PN}_Data/
+ rm -r "${ED}/${DIR}"/${MY_PN}_Data/*/$(usex amd64 x86 x86_64) || die
+
+ # Some Unity games have a GUI launcher but this one doesn't use it.
+ rm "${ED}/${DIR}"/${MY_PN}_Data/Plugins/*/ScreenSelector.so || die
+
+ newicon -s 128 ${MY_PN}_Data/Resources/UnityPlayer.png ${PN}.png
+ make_desktop_entry ${PN} "BFF or Die"
+}
diff --git a/games-puzzle/bff-or-die/metadata.xml b/games-puzzle/bff-or-die/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-puzzle/bff-or-die/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>