summaryrefslogtreecommitdiff
path: root/games-puzzle/amoebax/amoebax-0.2.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /games-puzzle/amoebax/amoebax-0.2.1-r2.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'games-puzzle/amoebax/amoebax-0.2.1-r2.ebuild')
-rw-r--r--games-puzzle/amoebax/amoebax-0.2.1-r2.ebuild32
1 files changed, 16 insertions, 16 deletions
diff --git a/games-puzzle/amoebax/amoebax-0.2.1-r2.ebuild b/games-puzzle/amoebax/amoebax-0.2.1-r2.ebuild
index a0b1fdd1e35a..8a53eb31d761 100644
--- a/games-puzzle/amoebax/amoebax-0.2.1-r2.ebuild
+++ b/games-puzzle/amoebax/amoebax-0.2.1-r2.ebuild
@@ -1,40 +1,40 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit autotools
-DESCRIPTION="A cute and addictive action-puzzle game, similar to tetris"
-HOMEPAGE="http://www.emma-soft.com/games/amoebax/"
-SRC_URI="http://www.emma-soft.com/games/amoebax/download/${P}.tar.bz2"
+DESCRIPTION="Cute and addictive action-puzzle game, similar to tetris"
+HOMEPAGE="https://www.emma-soft.com/games/amoebax/"
+SRC_URI="https://www.emma-soft.com/games/amoebax/download/${P}.tar.bz2"
LICENSE="Free-Art-1.2 GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="media-libs/libsdl[sound,joystick,video]
+DEPEND="
+ media-libs/libsdl[sound,joystick,video]
media-libs/sdl-image[png]
media-libs/sdl-mixer[vorbis]"
-RDEPEND=${DEPEND}
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-aclocal.patch
+ "${FILESDIR}"/${P}-clang.patch
+ "${FILESDIR}"/${P}-compile.patch
+)
src_prepare() {
default
- eapply \
- "${FILESDIR}"/${P}-aclocal.patch \
- "${FILESDIR}"/${P}-compile.patch
-
sed -i \
- -e "/^SUBDIRS/s:doc ::" \
+ -e "/^SUBDIRS/s|doc ||" \
Makefile.am || die
sed -i \
- -e "/^iconsdir/s:=.*:=/usr/share/pixmaps:" \
- -e "/^desktopdir/s:=.*:=/usr/share/applications:" \
- data/Makefile.am || die
- sed -i \
-e '/Encoding/d' \
-e '/Icon/s/.svg//' \
data/amoebax.desktop || die
+
AT_M4DIR=m4 eautoreconf
}