summaryrefslogtreecommitdiff
path: root/games-mud/gnome-mud/gnome-mud-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-mud/gnome-mud/gnome-mud-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-mud/gnome-mud/gnome-mud-9999.ebuild')
-rw-r--r--games-mud/gnome-mud/gnome-mud-9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-mud/gnome-mud/gnome-mud-9999.ebuild b/games-mud/gnome-mud/gnome-mud-9999.ebuild
new file mode 100644
index 000000000000..074b3bad3d25
--- /dev/null
+++ b/games-mud/gnome-mud/gnome-mud-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2 git-r3
+
+DESCRIPTION="GNOME MUD client"
+HOMEPAGE="https://wiki.gnome.org/Apps/GnomeMud"
+SRC_URI=""
+EGIT_REPO_URI="git://git.gnome.org/gnome-mud"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug gstreamer"
+
+RDEPEND="virtual/libintl
+ >=dev-libs/glib-2.36:2
+ >=x11-libs/gtk+-2.24.0:2
+ >=x11-libs/vte-0.11:0
+ dev-libs/libpcre
+ gnome-base/gconf:2
+ gstreamer? ( media-libs/gstreamer:1.0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-text/rarian
+ >=dev-util/intltool-0.23
+ >=sys-devel/gettext-0.11.5"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable gstreamer) \
+ $(use_enable debug debug-logger)
+}
+
+src_install() {
+ DOCS="AUTHORS BUGS ChangeLog NEWS README ROADMAP" \
+ gnome2_src_install
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+}