summaryrefslogtreecommitdiff
path: root/games-mud/crystal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-mud/crystal
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-mud/crystal')
-rw-r--r--games-mud/crystal/Manifest5
-rw-r--r--games-mud/crystal/crystal-0.2.4-r1.ebuild40
-rw-r--r--games-mud/crystal/files/crystal-0.2.4-build.patch28
-rw-r--r--games-mud/crystal/files/crystal-0.2.4-gcc43.patch11
-rw-r--r--games-mud/crystal/metadata.xml8
5 files changed, 92 insertions, 0 deletions
diff --git a/games-mud/crystal/Manifest b/games-mud/crystal/Manifest
new file mode 100644
index 000000000000..1b4a51028f25
--- /dev/null
+++ b/games-mud/crystal/Manifest
@@ -0,0 +1,5 @@
+AUX crystal-0.2.4-build.patch 916 BLAKE2B 90529e6be405c8f137041252109ad12a33a075baf3f3deab1c1f2279a26d49f3cd076e240e002e62f422c4fa25aef43aacd0daa643344a700cb9b9a7db586ee3 SHA512 4e3446634ca2996fecde8c9a12e2cc8d0900862dc2019cc0b260e58b5a1222f7e9b4faeeffc30f560dcaf97d83e1113800b19af36b054dbff9ed0b99296e777b
+AUX crystal-0.2.4-gcc43.patch 194 BLAKE2B 43b2ad908ea17e3b7c6123492a2c28a5dc0f3a0210d09a125efaab48d8da370b85d30538ccf3ee4b9e7af7ee46c7a2d5105b5d67982414610040fe4be296361d SHA512 98fbde01a18f36edabf8e324e1c5b7c12026032c59e5b628519cc21027e9553dda5d76fd1458f851ff9796d49f697b76f6f11fde85fbfdb433bcf05abdbf1021
+DIST crystal-0.2.4.tar.gz 146962 BLAKE2B 0b98e7db594ea27be26d7391c1f1ee8cdbf3239b9d841ebebf61d1022e492e3791057b70ddbe67f3da2e4a93c5b2d3f390ee2852cb489cbad7426b14661b7de0 SHA512 8493b0d84db610606ce97e918cfa418123c39e5afffb4bf880aa905c46dc13d0b7ff0366b497e020276afadf9db951fcd6fa7aa0e25f5357574fa465ee152916
+EBUILD crystal-0.2.4-r1.ebuild 748 BLAKE2B 636fd486c1f060124a75f18745449c34a7d0eefd8b8d0996e77a20ab5d2367cfd925c8562e15d2215c1bd606a5f15f98d71ef1a3bd2e7a40c40659361dbc818d SHA512 ce1df203325428707f3df00755fdf17f39ad5aa0d6b0bb6d97f6e170411f3d3a7e8476503c750ce874b499902559faf796e3512855391451130efabfd49ad8eb
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-mud/crystal/crystal-0.2.4-r1.ebuild b/games-mud/crystal/crystal-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..c5f5e04e44bf
--- /dev/null
+++ b/games-mud/crystal/crystal-0.2.4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="The crystal MUD client"
+HOMEPAGE="http://www.evilmagic.org/crystal/"
+SRC_URI="http://www.evilmagic.org/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/openssl:0=
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-build.patch
+)
+
+src_prepare() {
+ default
+
+ # avoid colliding with xscreensaver (bug #281191)
+ mv crystal.6 crystal-mud.6 || die
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-scripting
+}
diff --git a/games-mud/crystal/files/crystal-0.2.4-build.patch b/games-mud/crystal/files/crystal-0.2.4-build.patch
new file mode 100644
index 000000000000..1f8917e4056d
--- /dev/null
+++ b/games-mud/crystal/files/crystal-0.2.4-build.patch
@@ -0,0 +1,28 @@
+--- a/configure.in
++++ b/configure.in
+@@ -31,7 +31,9 @@
+ AC_PROG_CXX
+ AC_CHECK_FUNCS(select socket strerror strstr)
+
+-AC_CHECK_LIB(curses, main, [LIBS=" -lcurses "], AC_CHECK_LIB(ncurses, main, [LIBS=" -lncurses "], AC_MSG_ERROR([No curses])))
++PKG_CHECK_MODULES([NCURSES], [ncurses])
++AC_SUBST([NCURSES_CFLAGS])
++AC_SUBST([NCURSES_LIBS])
+
+ AC_CHECK_LIB(z, main, [LIBS=$LIBS" -lz "; AC_DEFINE(HAVE_ZLIB)], AC_MSG_WARN([No zlib - MCCP support will not be built]))
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -5,7 +5,11 @@
+ common.h crystal.h grid.h io.h telnet.h wcwidth.c \
+ scripting.cc scripting.h
+
+-man_MANS = crystal.6
++crystal_CPPFLAGS = $(NCURSES_CFLAGS)
++
++crystal_LDADD = $(NCURSES_LIBS)
++
++man_MANS = crystal-mud.6
+
+ DEBDIST = README.Debian debian/changelog.real debian/compat debian/control debian/copyright debian/crystal-default.ex debian/crystal.substvars debian/docs debian/rules debian/watch.ex
+
diff --git a/games-mud/crystal/files/crystal-0.2.4-gcc43.patch b/games-mud/crystal/files/crystal-0.2.4-gcc43.patch
new file mode 100644
index 000000000000..dbb4e2a1649f
--- /dev/null
+++ b/games-mud/crystal/files/crystal-0.2.4-gcc43.patch
@@ -0,0 +1,11 @@
+--- a/common.h
++++ b/common.h
+@@ -3,6 +3,8 @@
+
+ #include <string>
+ #include <stdio.h>
++#include <cstring>
++#include <cstdlib>
+ #include <curses.h>
+ #include <termios.h>
+ #include <sys/ioctl.h>
diff --git a/games-mud/crystal/metadata.xml b/games-mud/crystal/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-mud/crystal/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>