summaryrefslogtreecommitdiff
path: root/games-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
commitb89a664f266dab3b9b5ddac2cb874f8869142370 (patch)
tree21d127b0b99c1505ba548bc05975b9fcecda871e /games-misc
parent7e662ec84fc13cef513542e4030f47017d030187 (diff)
gentoo auto-resync : 13:10:2022 - 01:41:21
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/Manifest.gzbin8763 -> 8941 bytes
-rw-r--r--games-misc/solarus-quest-editor/Manifest5
-rw-r--r--games-misc/solarus-quest-editor/files/solarus-quest-editor-1.6.5-fix-segfault.patch22
-rw-r--r--games-misc/solarus-quest-editor/metadata.xml14
-rw-r--r--games-misc/solarus-quest-editor/solarus-quest-editor-1.6.5.ebuild55
-rw-r--r--games-misc/solarus-quest-editor/solarus-quest-editor-9999.ebuild55
6 files changed, 151 insertions, 0 deletions
diff --git a/games-misc/Manifest.gz b/games-misc/Manifest.gz
index d5c3a6fae9db..998b85a3db90 100644
--- a/games-misc/Manifest.gz
+++ b/games-misc/Manifest.gz
Binary files differ
diff --git a/games-misc/solarus-quest-editor/Manifest b/games-misc/solarus-quest-editor/Manifest
new file mode 100644
index 000000000000..0e339cc914bc
--- /dev/null
+++ b/games-misc/solarus-quest-editor/Manifest
@@ -0,0 +1,5 @@
+AUX solarus-quest-editor-1.6.5-fix-segfault.patch 840 BLAKE2B a8ce737577e38a19f7b4b32a4402c8a81fa882b1c8d09a8b6a226a9b78b2f3237a85d37865ba8395040d56c7e4142f03c60d5386a0fc27a71e962946ed2c89ea SHA512 397a485257b093181764268bf2be1d78358c688528fb606ae1cfe074dbefa95139058dd1c068e8c32a06e90d6130f49ad98607b36beaf1a3da52e244d07933b2
+DIST solarus-quest-editor-v1.6.5.tar.gz 58066380 BLAKE2B faf6d5a0512e7a3d462326461d400d272534fd7b671318b4fefdf4f4eac05860228542b6e0738cdb2c6a4faf43e5de404f5815ac44ad877340caf015e0673749 SHA512 1c38ce284ebc87289e137fa9703a9fa093b38bc74bc1f89b3e1e53caacac57ffa35e598e8705171c3e5204342d58eacacf28550b4b8834c5ba7a8b5eec052393
+EBUILD solarus-quest-editor-1.6.5.ebuild 1295 BLAKE2B 166fac4bcee0c1037d64e86ed02685364725ca19ea214ac9cc622f12e4087210f506cf35a755fc2e3ffbf166972e96465b606d3afec65d77fe74655138d6bf57 SHA512 fafcac3457944a1d9496d22307d5a778f614ce56b0f35cce30afd44de217f3b3fedc69d4e9d34a20b07fac1bb8d1279f405ed043b13d62b493ac7e058e1ace75
+EBUILD solarus-quest-editor-9999.ebuild 1295 BLAKE2B 166fac4bcee0c1037d64e86ed02685364725ca19ea214ac9cc622f12e4087210f506cf35a755fc2e3ffbf166972e96465b606d3afec65d77fe74655138d6bf57 SHA512 fafcac3457944a1d9496d22307d5a778f614ce56b0f35cce30afd44de217f3b3fedc69d4e9d34a20b07fac1bb8d1279f405ed043b13d62b493ac7e058e1ace75
+MISC metadata.xml 455 BLAKE2B ad0358283cae10032484396ed235845f507b0c69a3efe2c9e58c9b4ccecdb6fc3d65d40f6abe5776ad548dd871cd303656c25aa9fcbd53cf7b73598a1519fbef SHA512 0a61eeaad01a78a9d322a7c5e23b2153fd719be6b9a0c3a6f461d3739d4a4409c09d0b3f51f87658a0b617f0e4de198faa36b80980b04305a0401eb1fe6cfc3d
diff --git a/games-misc/solarus-quest-editor/files/solarus-quest-editor-1.6.5-fix-segfault.patch b/games-misc/solarus-quest-editor/files/solarus-quest-editor-1.6.5-fix-segfault.patch
new file mode 100644
index 000000000000..1e2f1582e2ce
--- /dev/null
+++ b/games-misc/solarus-quest-editor/files/solarus-quest-editor-1.6.5-fix-segfault.patch
@@ -0,0 +1,22 @@
+Solarus quest editor will segfault on startup with -O2
+
+See: https://gitlab.com/solarus-games/solarus-quest-editor/-/commit/921ac6170a08dcfe601c7a11ee9f7c85386a4f3f
+--- a/src/widgets/main_window.cpp
++++ b/src/widgets/main_window.cpp
+@@ -1287,7 +1287,6 @@ void MainWindow::current_editor_changed(int index) {
+
+ Editor* editor = get_current_editor();
+ const bool has_editor = editor != nullptr;
+- ViewSettings& view_settings = editor->get_view_settings();
+
+ // Set up toolbar buttons for this editor.
+ ui.action_cut->setEnabled(has_editor);
+@@ -1343,6 +1342,8 @@ void MainWindow::current_editor_changed(int index) {
+
+ if (has_editor) {
+
++ ViewSettings& view_settings = editor->get_view_settings();
++
+ connect(&view_settings, &ViewSettings::zoom_changed,
+ this, &MainWindow::update_zoom);
+ update_zoom();
diff --git a/games-misc/solarus-quest-editor/metadata.xml b/games-misc/solarus-quest-editor/metadata.xml
new file mode 100644
index 000000000000..849001522d1b
--- /dev/null
+++ b/games-misc/solarus-quest-editor/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>Matt.Jolly@footclan.ninja</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">solarus-games/solarus-quest-editor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-misc/solarus-quest-editor/solarus-quest-editor-1.6.5.ebuild b/games-misc/solarus-quest-editor/solarus-quest-editor-1.6.5.ebuild
new file mode 100644
index 000000000000..8a1fcd50dab2
--- /dev/null
+++ b/games-misc/solarus-quest-editor/solarus-quest-editor-1.6.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-1 luajit )
+
+inherit cmake lua-single
+
+DESCRIPTION="This is the package for people who want to create Solarus quests. It expands the player's package with game-making tools."
+HOMEPAGE="https://www.solarus-games.org"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/solarus-games/solarus-quest-editor.git"
+ EGIT_BRANCH="dev"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.com/solarus-games/solarus-quest-editor/-/archive/v${PV}/solarus-quest-editor-v${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/solarus-quest-editor-v${PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# Upstream (and their CMake) claim that all of these are required deps
+RDEPEND="
+ ${LUA_DEPS}
+ dev-games/physfs
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/libmodplug
+ >=media-libs/libsdl2-2.0.1[X,joystick,video]
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl2-image[png]
+ >=media-libs/sdl2-ttf-2.0.12
+"
+
+DEPEND="
+ ${RDEPEND}
+ ~games-engines/solarus-${PV}
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-segfault.patch"
+)
+
+src_configure() {
+ local mycmakeargs=( -DSOLARUS_USE_LUAJIT="$(usex lua_single_target_luajit)" )
+ cmake_src_configure
+}
diff --git a/games-misc/solarus-quest-editor/solarus-quest-editor-9999.ebuild b/games-misc/solarus-quest-editor/solarus-quest-editor-9999.ebuild
new file mode 100644
index 000000000000..8a1fcd50dab2
--- /dev/null
+++ b/games-misc/solarus-quest-editor/solarus-quest-editor-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-1 luajit )
+
+inherit cmake lua-single
+
+DESCRIPTION="This is the package for people who want to create Solarus quests. It expands the player's package with game-making tools."
+HOMEPAGE="https://www.solarus-games.org"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/solarus-games/solarus-quest-editor.git"
+ EGIT_BRANCH="dev"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.com/solarus-games/solarus-quest-editor/-/archive/v${PV}/solarus-quest-editor-v${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/solarus-quest-editor-v${PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# Upstream (and their CMake) claim that all of these are required deps
+RDEPEND="
+ ${LUA_DEPS}
+ dev-games/physfs
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/libmodplug
+ >=media-libs/libsdl2-2.0.1[X,joystick,video]
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl2-image[png]
+ >=media-libs/sdl2-ttf-2.0.12
+"
+
+DEPEND="
+ ${RDEPEND}
+ ~games-engines/solarus-${PV}
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-segfault.patch"
+)
+
+src_configure() {
+ local mycmakeargs=( -DSOLARUS_USE_LUAJIT="$(usex lua_single_target_luajit)" )
+ cmake_src_configure
+}