summaryrefslogtreecommitdiff
path: root/games-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /games-misc
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/Manifest.gzbin9100 -> 9100 bytes
-rw-r--r--games-misc/ponysay/Manifest3
-rw-r--r--games-misc/ponysay/files/ponysay-3.0.3-python-syntax.patch38
-rw-r--r--games-misc/ponysay/ponysay-3.0.3.ebuild8
4 files changed, 46 insertions, 3 deletions
diff --git a/games-misc/Manifest.gz b/games-misc/Manifest.gz
index 5c51ef407a0a..4c8396acf93c 100644
--- a/games-misc/Manifest.gz
+++ b/games-misc/Manifest.gz
Binary files differ
diff --git a/games-misc/ponysay/Manifest b/games-misc/ponysay/Manifest
index b6c84b3012c2..1349e15b236b 100644
--- a/games-misc/ponysay/Manifest
+++ b/games-misc/ponysay/Manifest
@@ -1,3 +1,4 @@
+AUX ponysay-3.0.3-python-syntax.patch 1584 BLAKE2B 5f13613d7a43df44662ebe9d6cb995bba3ee8629cdf45546e895bbda64bea03029db25d0dc75c2263f77fd51c3b8d2d43f5aa7d48c02089b1413f191e7888a29 SHA512 d28d85313881e2e48c3648db0f99686a2d5facd82cb771219737075043d162047190a4e7a9cadac15b20c6081add90029535e8b1e17dfdca191f6d8e994c25ed
DIST ponysay-3.0.3.tar.gz 2139074 BLAKE2B 3ba477268d68ff9a92bad8028d0b960a2a6152057146368723fea432100a71517c0c343d34b2b1c580fcfa1945bdc273fed276cf4a10c702514e6699cda87a2c SHA512 d6ff905404192bdc207952a4a914458d7f25ddcfcea95763ae277a2a3bc7ab33e86a0a229c1b10ff7295b7a89d6e1b61406feefb6bdf9026f4076d0ed70dbe93
-EBUILD ponysay-3.0.3.ebuild 1458 BLAKE2B 5a6cb0a5501fc7d5252cf5ef3d2ca77ae72eead0932e57aa42f6869c452bbc4a40ae74772438c8dbbaf1cf50d3f6ec028e6c441649c67125dd4f54b01434c645 SHA512 f2f4a1a9cb1a94228971bf6031fc6c498a17a3fc6a0340e77925a4b8f00ffbc6988f3f59105cacf3163d0b1c639fe1103ed89397c3fadee6bf573d16799d666a
+EBUILD ponysay-3.0.3.ebuild 1522 BLAKE2B 21ba3442698ce2558b8235b2e7974fb09766e1ada4088850d5a7cebc8ee61a307eae7705305c0b320a5ef6ec0614b5f4d91a50120c8c8af87180042976182ac0 SHA512 21cf95c259eb340b4aab7a5ce2499227feb156a3d9441aaea8aed0f138711b2b6e5231da47e50f06e775f62ca4cc80bd0f23e744f557d5beefe610a424630b37
MISC metadata.xml 500 BLAKE2B a937b3dcb9fb8a11ceefa20731973096578f503d711731a22afd3fbaea75b25d37cb736af36fbe8696a0d01afca261a4156444ac6b26b9a87f30f29d785f7408 SHA512 612eee4d25e1f3e3ef18b08ac4fcf59fbee5ab179d1f4da5e6784909c1985aa816317eba1a4c1a0aae8b1dfc0bfcc63ea44ab844b1400e565a2ebfaf5d7f8d4c
diff --git a/games-misc/ponysay/files/ponysay-3.0.3-python-syntax.patch b/games-misc/ponysay/files/ponysay-3.0.3-python-syntax.patch
new file mode 100644
index 000000000000..de35149fcdff
--- /dev/null
+++ b/games-misc/ponysay/files/ponysay-3.0.3-python-syntax.patch
@@ -0,0 +1,38 @@
+https://github.com/erkin/ponysay/commit/f9154fd806bbf31c79b1769b13d5aa1b67f9c06a.patch
+(and an additional fix)
+
+From f9154fd806bbf31c79b1769b13d5aa1b67f9c06a Mon Sep 17 00:00:00 2001
+From: adasiko <adasiko256@yandex.ru>
+Date: Sun, 22 Mar 2020 19:33:28 +0700
+Subject: [PATCH] fix: do not compare literal with "is not"
+
+---
+ src/ponysaytool.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/ponysaytool.py b/src/ponysaytool.py
+index 7f9a4da5..574a2baa 100755
+--- a/src/ponysaytool.py
++++ b/src/ponysaytool.py
+@@ -1002,7 +1002,7 @@ def alert(text):
+ for row in range(0, len(datalines)):
+ current = leftlines[row]
+ if len(datalines[row].strip()) == 0:
+- if current is not 'comment':
++ if current != 'comment':
+ if current != last:
+ self.datamap[current] = None
+ continue
+diff --git a/src/backend.py b/src/backend.py
+index 2cc539a..82ff149 100755
+--- a/src/backend.py
++++ b/src/backend.py
+@@ -291,7 +291,7 @@ class Backend():
+ props = dollar[7:]
+ if len(props) > 0:
+ if ',' in props:
+- if props[0] is not ',':
++ if props[0] != ',':
+ w = props[:props.index(',')]
+ h = int(props[props.index(',') + 1:])
+ else:
diff --git a/games-misc/ponysay/ponysay-3.0.3.ebuild b/games-misc/ponysay/ponysay-3.0.3.ebuild
index 5c758bbc2106..00fedbca4e25 100644
--- a/games-misc/ponysay/ponysay-3.0.3.ebuild
+++ b/games-misc/ponysay/ponysay-3.0.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit bash-completion-r1 python-single-r1
DESCRIPTION="cowsay reimplemention for ponies"
@@ -22,6 +22,10 @@ RDEPEND="${PYTHON_DEPS}
fish-completion? ( app-shells/fish )
zsh-completion? ( app-shells/zsh )"
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.3-python-syntax.patch"
+)
+
setup_py() {
"${PYTHON}" setup.py \
--prefix="${EPREFIX}"/usr \